Cannot record system audio in Lion OSX

Discussion in 'Digital Audio' started by stringzz, Oct 24, 2011.

  1. stringzz macrumors member

    stringzz

    Joined:
    Jan 4, 2008
    #1
    I used to be able to record system audio in Leopard using Wiretap Pro 1.3.4. Now I get the following error after I upgraded to Lion:

    "kext not found unable to record mac audio"

    I tried downloading AudioHijack Pro and I also get an error:

    "NSLocalizedRecoverySuggestion: We were unable to capture all system audio. The System Audio device could not be set as system default output."

    Any ideas?

    Thanks
     
  2. heldausberlin macrumors newbie

    Joined:
    Oct 26, 2011
    #2
    Hi, I had the same problem.
    My solution was to install WireTap Studio as trial version. After that WireTap Pro worked fine, so I could deleted WireTap Studio to work with WireTap Pro again.
     
  3. Montalvo macrumors newbie

    Joined:
    Nov 19, 2011
    #3
    Yup.. I can confirm that.
    After several attemps to make it work, was just after I downloaded trial of Studio version, that it works. So this is a valid solution.
    :)
     
  4. ilyaqq macrumors newbie

    Joined:
    May 5, 2012
    #4
    YESS! It works!

    It needs:
    1)to install WireTap Studio as trial
    2)ask WireTap Studio to record audio from "Mac audio" (in the bottom choice window)
    3)Then WireTap Studio says, it can not record from "Mac audio", since there is no special kext in system. And propose to install this kext automatically.
    Say yes-yes-yes, and system will install this kext.

    4)And now WireTap Pro do works too.
     

Share This Page