Cannot reinstall the Snow Leopard nor install windows with boot camp

Discussion in 'macOS' started by tigtig, Feb 13, 2010.

  1. tigtig macrumors newbie

    Joined:
    Feb 13, 2010
    #1
    Hi

    I've been having big problems trying to solve my problem. I've checked all the posts related, tried all the solutions and still I didn't get anything, so I'm sharing my problem and hope for someone to have the solution.

    I installed Windows XP with BootCamp and it was working fine.
    But then the HD space of the windows partition was too small and I needed more space. So what I did was erase the partition with the Disc Utility.

    But before that I wanted to test the Parallels to see if the windows 7 would work fine with it. It installed easily but I didn't like the performance of it, so I just erased it with the AppCleaner.

    Then I erased the BootCamp partition with Disc Utility. No problem.

    But when I tried to use the Boot Camp Assistant again, it only gave me the message: "The Disk Cannot Be Partitioned Because Some Files Cannot Be Moved"

    I've checked the forums and it was said that probably if I use iDefrag, it would solve my problem.

    Once I did it, I still got the same message.

    Then I decided to repair the dic, so I did the verification and clicked on Repair Disc Permitions and I've got this message:
    -The file SUID "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" was modified and cannot be repaired.

    Then I decided to reboot the whole system inserting the installation disc and pressing the C button, but all I get is a white screen and no response. And sometimes the Macbook not even start properly (also having only the white screen and no response), so I need to press the Option button till the Mac HD icon appears and I can access the computer.

    And now I really without any option and I wanted to install the windows.
    Is there anyone that can help me?
     
  2. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #2
    Resetting your PRAM may help with startup issues.
     
  3. tigtig thread starter macrumors newbie

    Joined:
    Feb 13, 2010
    #3
    Well, I just resetted the PRAM and when I tried to resinstall the Mac OS X, It askes to restart, and I still get the white screen.
     
  4. tigtig thread starter macrumors newbie

    Joined:
    Feb 13, 2010
    #4
    The PRAM resetting did work, but when I insert the Mac OSX disc, it refuses to restart....

    I even tried to hold press the Option button and the disc image appears, but when I click on it, the screen freezes.
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5
    Make appointment with apple store genius bar if you are under warranty.
     

Share This Page