Cannot remove a screw - Optibay - please help!

Discussion in 'Mac Basics and Help' started by jon08, Dec 4, 2011.

  1. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #1
    So I tried to remove the Superdrive today to install the OWC Data Doubler in my MBP, but I cannot unscrew one of the screws with the OWC kit.

    I've tried other screwdrivers too, but none of them worked and now I've kind of stripped that screw.

    I'm really desperate and don't know what to do next. Please help!

    [​IMG]

    [​IMG]
     
  2. jekyl macrumors 6502

    jekyl

    Joined:
    Mar 6, 2011
    Location:
    Mid-Michigan
    #2
    I think it's time to either reassemble everything and give up on upgrading or take the laptop in to a professional.
     
  3. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #3
    If you are patient and cautious, you can use JB Weld (or a similar strong epoxy) and a driver or stiff piece of metal to get the screw out, though the screw is toast afterward.

    I had to do this to get a screw out of a 17" G4 Power book once. It took a lot of time and patience. You need an epoxy that can handle the torsion force unscrewing puts on it.
     

Share This Page