Resolved Cannot remove folders from Time Machine blacklist

Discussion in 'OS X Yosemite (10.10)' started by poiihy, Dec 30, 2014.

  1. poiihy, Dec 30, 2014
    Last edited: Dec 31, 2014

    poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #1
    There are some folders in the Time Machine blacklist that I want to remove. I can select them all and remove them but when I close (clicking Save) the thing and open it again, it is there again! :mad:
     
  2. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #2
    Well... I *think* I know what you are asking, so I'll try to answer what I think you are asking.

    With your Time Machine Backup Disk connected (I, personally, keep mine disconnected -- but maybe your's is connected all the time), click on your little Time Machine icon and select "Enter Time Machine."

    Then, when you see your files, directories and folders and stuff, RIGHT-CLICK on one of them, and a popup will appear asking if you want to DELETE them from future backups...

    At that point, you can decide if my answer is the answer to your question and that's what you wanted to do...

    Hopefully I helped! :)

    Post back, if I didn't, and I'll try again :D
     
  3. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    I think he wanted the opposite :)

    Try repairing permissions; it seems that the system can't write to the settings file.
     
  4. poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #4
    No...

    In Time Machine preference pane in System Preferences, there is an "Options..." button in the lower right corner. Here you can set which folders and files to exclude from backup.

    I cannot remove anything from it. Everytime I remove it, it is back there again when I reopen it.
     

    Attached Files:

  5. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #5
    Okay I understand now.
    In the list that you blackened out with a pen... is that a list of files?

    Or is it a list of various Hard Drive names?

    If there is a hard drive you want *excluded* from that list (so that it won't "reappear"), then what you will want to do is search that specific hard drive for a file called "Backups.backupdb" and remove it.

    For example, if I have a drive in the list called "My_Shiny_New_Backup_Drive," then I will start up an application I have called "Find Any File," (you can use Spotlight, I think... I don't know, I've disabled Spotlight), and search "My_Shiny_New_Backup_Drive" for that file I mentioned, "Backups.backupdb" and it appears to be in the root level of the drive. I drag that into Trash, and empty the Trash.

    Now, from now on, Time Machine will stop recognizing it as a valid backup drive, and theoretically, that will keep it from reappearing.

    Does that help?
     
  6. poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #6
    They are directories on my local volume. I know the thing about the external drive... Time Machine prevents backing up the drive to itself (I wonder what would happen if you could do that :p )
     
  7. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #7
    Hmmm... that's really weird. I don't have anything in my Backup Exclude list, otherwise I'd try some experiments...

    But, maybe you can launch Terminal and snoop into those directories and see if there is an invisible file in there (named something like .backups.backup or something that you can remove)?

    I guess worst-case scenario is to delete the Time Machine preferences.... but if you DO delete the preferences, I think Time Machine will forget your incremental backups, and end up tying up your computer for several hours redoing a FULL backup, instead of the usual 45-second incrementals.

    Ya, I'd launch terminal, and cd into it:
    cd /Users/MyUserName/Desktop/MyFolderThatKeepsReappearing

    and then type
    ls -ainrst

    which will give you a list of all the visible and invisible files in that folder, in order of recent-ness.
     
  8. ItWasNotMe macrumors regular

    Joined:
    Dec 1, 2012
    #8
  9. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #9
    It seems all those folders on the blacklist have the little red no go sign attach to it. May be that's the problem. Do you have permission to access those folders?
     
  10. poiihy, Dec 31, 2014
    Last edited: Dec 31, 2014

    poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #10
    Most of the folders have restricted priviledges (They are folders inside other users' accounts but the one on top is my home folder which I have full access to.

    Maybe there is a permissions problem with the file where the settings are saved? Where is that file?
    edit; nvm Found it on google
    /Library/Preferences/com.apple.TimeMachine.plist

    I deleted it (and the lockfile) but the Time Machine is still like it was! I will try restart
    edit: NOPE still there EVEN THOUGH I deleted the config! :mad:
    There is a replacement config file there exactly like before!
    Where is it getting it from?!
    Well I will try editing the file and removing the excluded items.

    Update: Edited the plist to remove the files... AND THEY'RE STILL THERE!!! The file completely reverted to original!
     
  11. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #11
    May be boot into the recovery partition, repair disk and permission until there is no more error will help.
     
  12. poiihy, Dec 31, 2014
    Last edited: Dec 31, 2014

    poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #12
    Repaired permissions but there was nothing about Time Machine. Problem still persists. Now I will Verify Disk.

    For some reason I cannot boot into recovery system. When I hold Command+R, it just reboots the machine repeatedly until I stop. When I hold option key, I don't see any recovery HDs. BTW, I am using rEFInd so maybe that has something to do with it?

    Can Leopard repair a Yosemite disk? I have a leopard partition I can use.
    Hmm... maybe I can delete that settings file from Leopard when Yosemite is not running. I'll try that after I verify disk.

    Edit: Verified disk and it is ok. I will try deleting that plist from Leopard.

    Edit: IT WORKED! YAY! I deleted the plist from the Leopard partition and it WORKED!
    So it looks like that plist was loaded into memory, so whenever I edit or delete it, it got reverted. When I deleted it remotely, from the Leopard partition, the Yosemite system was not loaded so it did not revert it or anything.
    :D
     
  13. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #13
    Review and explanations

    Whilst there's a resolution, there are also opportunities to learn from this topic.

    Unable to start Recovery OS

    Ensure that you release the Command and R keys at the appropriate time.

    OS X: About OS X Recovery – Apple Support

    If the problem is reproducible: please start a new topic, or find one with a subject line that matches the symptoms in your case.

    Startup Manager and Recovery OS

    If the OS X startup volume associated with that Recovery OS is encrypted with Core Storage (e.g. FileVault 2), then it's normal for Startup Manager to not show that Recovery OS.

    Using an old OS to attempt repairs to a modern OS

    Repairs to an HFS Plus file system? Don't take the risk.

    Permissions? These are normally file system agnostic. The accepted answer to a comparable question in Ask Different (To repair permissions for Lion, is it safe to use Disk Utility in Recovery OS for Mountain Lion?), with additional emphasis:

    Defaults (preferences)

    That's a reasonable guess, but the technical explanation is somewhat complex. Please see the accepted answer to the following question, in Ask Different:

    Why is a command line change to ~/Library/Preferences/com.apple.LaunchServices.plist not effective immediately?


    Are the other people both normal users? ​

    (A guess: neither is allowed to administer the computer.)

    When you used System Preferences to skip your own home directory, was that done whilst logged in as someone else?​

    Ideally, the lock-free administrator's view of the Time Machine pane should not, so easily, show the metadata of other users. Consider the attached screenshots, which I prepared for this topic.

    Attention to permissions will make no difference in cases such as this; the relevant .plist is owned by root.

    That's a good point of reference.

    The following example may be read alongside the two screenshots. Note the extended attribute on one of the files.

    Code:
    sh-3.2$ sw_vers
    ProductName:	Mac OS X
    ProductVersion:	10.9.5
    BuildVersion:	13F34
    sh-3.2$ whoami
    gjp22
    sh-3.2$ defaults read /Library/Preferences/com.apple.TimeMachine SkipSystemFiles
    0
    sh-3.2$ defaults read /Library/Preferences/com.apple.TimeMachine SkipPaths
    (
        "/Applications/archive",
        "/Library/Backblaze.bzpkg",
        "~yes/Documents/assisted suicide"
    )
    sh-3.2$ defaults read /Library/Preferences/com.apple.TimeMachine ExcludedVolumeUUIDs
    (
        "AD0D732F-9769-32D0-A4E7-8E8554705BE1"
    )
    sh-3.2$ defaults read /Library/Preferences/com.apple.TimeMachine ExcludeByPath
    (
        "/Users/Shared/adi",
        "/Volumes/gjp22/Library/Application Support/DriveGenius/Logs",
        "/Users/gjp22/Library/Application Support/DriveGenius/Logs",
        "/Users/gjp22/Library/LaunchAgents/com.prosofteng.DGMonitor.plist",
        "/Library/Application Support/Microsoft/PlayReady",
        "/Library/Application Support/DriveGenius"
    )
    sh-3.2$ ls -@dl /Users/yes/Documents/top\ secret
    ls: /Users/yes/Documents/top secret: Permission denied
    sh-3.2$ sudo ls -@dl /Users/yes/Documents/top\ secret
    drwxr-xr-x@ 2 gjp22  wheel  68  1 Jan 08:43 /Users/yes/Documents/top secret
    	com.apple.metadata:com_apple_backup_excludeItem	61 
    sh-3.2$ ls -l /Library/Preferences/com.apple.TimeMachine.plist
    -rw-r--r--  1 root  wheel  74238  1 Jan 08:58 /Library/Preferences/com.apple.TimeMachine.plist
    sh-3.2$ 
    
    Screenshots of the Time Machine Pane of System Preferences in Mavericks

    Prepared specifically for this topic. Towards an explanation of symptoms that were observed by the opening poster.

    To a normal user, the locked view after someone else's admin credentials were used to exclude something within the normal user's home directory:

    [​IMG]

    To an administrator:

    [​IMG]

    Note the absence of a padlock icon, and so on …
     

    Attached Files:

  14. poiihy thread starter macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #14

    When I hold Command+R, the system restarts in a loop before showing the display... Like doing a PRAM reset.

    The "Other users" listed are the same user and that same user is an Administrator. I think my hold folder was added from another user but I cannot be sure; it was a long time ago.

    If this is relevant, when I was having problems with installing Yosemite while trying to solve my random crashing problem (found to be bad ram), i was trying stuff to get back running and one stupid thing I did was set all the permissions of the Users folder to R/W for me (on a different computer connected with target disk mode) so I could move the Users folder back... Messed up all the permissions and had to reconfigure them manually. That probably caused minor problems here and there. I need a fresh install which is why I backed this up
     
  15. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #15
    Reproducible

    poiihy, thanks for the additional information.

    The simplest (non-technobabble) footnote that I can add to this topic:
    • the System Preferences behaviour observed by you – before this topic was resolved – is easily reproducible :)
     

Share This Page