Cannot Repartition Drive in Boot Camp Assis. OR with Leopard Disk

Discussion in 'macOS' started by makasin, Apr 17, 2008.

  1. makasin macrumors member

    Joined:
    Oct 28, 2007
    #1
    Ok guys so im stumped. I have 51GB left of my 250GB drive inside my MBP. I'm trying to install windows and create a 32gig partition, leaving me with 19GB left in OSX. I tried to re-partition the disk using the Boot Camp Assistant, and it says "ERROR: Some files couldn't be moved". Then I boot up using my Leopard Disk, do a repair, permission repair, and try to do the same setup in Disk Util. That didn't work, it said the disk was full. I tried a smaller number for the FAT drive. I tried 20GB, 15GB, I tried formatting the 2nd partition to Free Space, HFS+ journaled and unjournalled, as well as FAT-32 of course. Nothing seems to work, I keep getting the same error regardless of the size, type, etc.

    Anyone have an answer? Did this happen to anyone? I kinda need to install XP to work on a homework assignment in this program called MatLab. Anyone know of an alternative to this in OSX? Should I just try to install it in Parallels? Is there any way to migrate the parallels file into a windows friendly partition to dual boot at a later time?
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    I've heard reports in other threads that this problem is most often caused by your Mac's "sleep file". Deleting this fixes it (the Mac OS will create a new one for you when needed). Alas, I can't seem to locate the thread where this was mentioned.
     
  3. makasin thread starter macrumors member

    Joined:
    Oct 28, 2007
    #3
    so i tried deleting the sleep image, i cleared up even more space. now i have 70+GB free and it still doesnt work. anybody got any other suggestions?
     

Share This Page