Cannot replace existing files in a folder

Discussion in 'OS X Yosemite (10.10)' started by SpandexAssassin, Nov 1, 2014.

  1. SpandexAssassin, Nov 1, 2014
    Last edited: Nov 1, 2014

    SpandexAssassin macrumors newbie

    Joined:
    Nov 1, 2014
    #1
    Hi all,
    I am having a problem with the Finder, Copy and Replace to be exact, and I was hoping someone could help me troubleshoot.

    The issue:
    When I copy a file into a folder where another file with the same name exists, nothing happens. I am able to copy files that do not exist in a folder without issues.

    What I think is happening:
    I believe the Finder does try to trigger whatever service is responsible for loading up the Copy and Replace dialog box because if I try to restart the computer after I have attempted replace an existing file I get an error message saying "The Finder can't quit because some operations are still in progress."

    At the point, the only way to be able to restart the computer is to Force Quit the Finder. Reloading the Finder about 4-5 times also fixes this issue and I am able to replace existing files.

    What I've tried:
    I went into Activity Monitor to see if I could figure out which process was responsible for copying and I narrowed it down to DesktopServicesHelper. I was hoping that if I could replace it with a know working copy, the issue would be resolved. I copied that file from my Macbook but the issue did not get resolved.

    I also reinstalled Yosemite on top of my existing Yosemite installation and the problem still persists. Lastly, I've run Disk Utility and repaired permissions a whole lot of times too.

    Anyone know what else I could try?

    Thanks in advance!
     
  2. Alimar macrumors 6502a

    Alimar

    Joined:
    Sep 17, 2014
    Location:
    New York State
    #2
    Have you tried to 'Repair Permissions' in Disk Utility?
     
  3. SpandexAssassin thread starter macrumors newbie

    Joined:
    Nov 1, 2014
    #3
    I have, many times but so far no dice.
     
  4. waxwing1 macrumors newbie

    Joined:
    Dec 30, 2008
    #4
    Same here

    Wish I had a solution but I'm encountering the same thing. I noticed it when trying to update apps. For instance, I've been unable to update Calibre since upgrading to Yosemite. I can't install from the DMG or drag and drop to the Applications folder. I was able to trash the app and then install but not on top of a previous file. Thanks for posting this since I didn't make the connection to inability to copy over a file.

    Two other things I'm encountering that I assume are related.

    1) The Launchpad app and the Downloads folder in the dock both show a progress bar though nothing, at this moment, is installing or downloading. I've tried to kill and restart the finder but that doesn't seem to help.

    2) I have frequent finder crashes when trying to drag and drop files from one location to another. I can grab the file and then start to drag it and all finder windows will disappear for a few moments. Then new finder windows open often not at the same spot where I was at the start of the crash.

    I was just going to restart my Mac Pro (2008) but received the message, "The Finder can't quit because some operations are still in progress." I Googled that phrase and ended up here.

    Haven't tried rebuilding permissions or reinstalling Yosemite. Also plan to restart and login as a different user. Obviously, constant finder crashes is a huge issue!
     
  5. SpandexAssassin thread starter macrumors newbie

    Joined:
    Nov 1, 2014
    #5
    I'm glad I'm not the only one since I couldn't find a post on google with this issue.

    Unfortunately, I still don't have an answer or a solution. When I have some time, I'll most likely try a clean install of Yosemite and see if that works but for now I'm being careful when copying.

    Also, I'm not having the same issues you are with the finder crashing. My install has been very stable with the only issue being the copy/replace problem. If I was you, I would try repairing permissions since it's pretty simple to do with Disk Utility.
     

Share This Page