Cannot reply to/forward mail over Wifi, only over EDGE

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kunalashar, Feb 4, 2009.

  1. kunalashar macrumors newbie

    Joined:
    Dec 20, 2008
    #1
    I have an iPhone 2G, 8GB, FW 2.2, jailbroken.

    The Problem
    • The iPhone is unable to reply to/forward any existing mails when it is connected over Wifi.
    • However, it is able to send all existing and new mails when it is connected over EDGE.
    • It is also able to send emails that originate from the iPhone; that is, I create a new email on my iPhone and send it.

    Wifi Connection Is Not A Problem
    I have 2 separate laptops connected to the Wifi, and the internet on both works fine. I am able to browse the net, and send and receive emails using multiple clients such as Outlook and Thunderbird. I am also able to browse the net using iPhone's Sarafi mobile browser, when connected to the Wifi.

    Wifi Security Is Not A Problem
    My Wifi is WPA-PSK secured, but I have the same problem even when I remove all wireless security (open).

    Problem With All Mail Servers
    I have multiple email accounts configured, including Gmail, AOL, Yahoo and several POP3 and IMAP servers. I am able to receive emails on ALL of them, but cannot reply to or forward any emails on ANY of them on the iPhone.
    I am, however, able to send emails that are created on the iPhone, from the from all of them.

    Has anyone faced this problem and found a solution? Or could someone please suggest a workaround?

    Thanks in advance.
     
  2. AlecMyrddyn macrumors 6502

    Joined:
    Dec 5, 2008
    Location:
    Southern Maine
    #2
    When you use WIFI, you are subject to the restrictions of the ISP that WIFI is connected to.

    Many ISPs/Network Admins these days block some types of outbound mail connections to prevent infected computers on their network from being able to spread viruses & worms, and to combat spam.

    One of the most common methods for doing this is to not allow any connections directed to port 25 on an IP outside of their network.

    There are a few potential fixes or workarounds:

    1. If your email account has SMTP-AUTH, and their SMTP server works on a port other than port 25, use that. Often, merely choosing to use SSL encryption (if supported) on your SMTP settings can do the trick. Many SMTP servers response on port 587, so you can try changing that. This technique will not always work. Some ISPs/Network Admins block all possible SMTP ports. But generally, switching from port 25 to 587 for non-SSL mail, or enabling SSL for SMTP (and switching to the proper port for that) will do the trick.
    2. Use your ISP's/Network's SMTP server. If all else fails, you should be able to use the WIFI network ISP's outbound mail server to send mail. This is obviously less than ideal, because you might have to change it depending on which WIFI network you are on.
    3. Use a webmail interface via Safari instead.

    As a last resort, check your laptop email server settings, and make sure that the iPhone settings match them. Keep in mind that these settings might not work when you leave that WIFI network.

    Finally, record any settings before you change them, so you can revert in the event of any problems.

    Good luck.
     
  3. kunalashar thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #3
    Thanks AlecMyrddyn; if the SMTP port is the problem, Gmail should work right?

    Gmail, which sends on smtp.gmail.com, port 587, using SSL, should have worked. That didn't work either. Same argument with AOL, which sends on smtp.aol.com, port 587, using SSL, but doesn't work on the iPhone (but works on my laptop).

    But the counter argument doesn't seem to work either. Yahoo sends on port 25, but that isn't working either. Similarly, the SMTP server of inbox.com, my.inbox.com, sends on port 25, and that doesn't work on the iPhone.

    In fact, my custom SMTP server, pro30.abac.com, which sends on port 465, doesn't work either!!!

    So I doubt if it's a problem with a specific port.

    You mentioned:
    But wouldn't that affect the sending of emails from my laptops which use the same settings as the iPhone? For example, Outlook is configured to send emails using pro30.abac.com on port 465, and that works. But the identical setting on my iPhone doesn't.

    My last option is obviously to use webmail, but that's ugly and defeats the purpose of the iPhone.
     
  4. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #4
    Have you tried restoring? I know it's a pain, but it'll help determine whether it's just a borked config or something trickier.
     
  5. AlecMyrddyn macrumors 6502

    Joined:
    Dec 5, 2008
    Location:
    Southern Maine
    #5
    Depends on how the phone is configured.

    That's odd. If the phone has all the same settings (same port, SSL enabled/disabled, hostname) and is on the sames wireless, and the wireless router doesn't have any particular firewall rules, it should work the same.

    Are you sure you are are joining the same wireless network as the laptops? Are you sure that the wireless router doesn't have any restrictions for some devices on the network?

    From the information you have provided, I also lean the same way - it doesn't sound like a port filtering issue.

    Port 465 is SMTP with SSL. In order to connect to it you must also have SSL enabled for sending in the Mail Settings area. If this is the case, again, it points to something about the iPhone itself, not ISP-level filtering.

    Given the additional information, it sounds specific to the iPhone.

    There are two options I can think of:

    1. The iPhone is having a problem with WIFI. Does this problem occur on all WIFI networks, or just this one? If just this one, I'd concentrate on the Router; if all WIFI networks, I'd concentrate on the iPhone. Have you tried a full reboot (power + home until it restarts)?
    2. The iPhone is somehow interacting badly with this specific wireless network. I'd suggest checking the router's settings (firewall especially), reboot the router, see if the router has a firmware update available, and perhaps resetting the router to defaults and reconfiguring it.
     
  6. kunalashar thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #6

    I'm going to try to do this on a different wireless network, and if that fails, it's a restore for me.
     
  7. kunalashar thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #7
    You're right. I'll try a different network in a few hours. I'm keeping my fingers and toes crossed.
    If it fails on those, I suppose the quickest way will be to restore the firmware (or upgrade to 2.2.1 - I've been meaning to do it anyway).

    Thanks!
     
  8. kunalashar thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #8
    Something screwy going on

    I had the same problem with a different Wifi. So the problem seemed to point to "borked" iPhone settings.

    So I restored the phone (actually updated to 2.2.1), re-jailbroke it. I ensured that none of my AppStore purchases were restored. I also didn't re-install any of my Cydia Apps. I configured a single account - a Gmail account, and tried the reply test over Wifi.

    It worked.

    Full of confidence, I added a Yahoo, an AOL, 1 custom POP3 and 1 custom IMAP account.

    Bam! The problem reappeared!!!

    I tried changing the Default Account from Gmail to another one, but no luck. The problem remained.

    Full of resentment, I deleted ALL the email accounts, and reconfigured just one Gmail account.

    Sure enough, it worked once again!!

    What in the name of Steve Jobs is going on???

    Anyone have any ideas?
     
  9. kunalashar thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #9
    Problem with an IMAP server amongst POP3?

    I was able to narrow down the problem to this:

    When I configure a custom mailbox as an IMAP, it breaks the reply/forward function within iPhone (???).

    I configured Gmail, Yahoo, AOL and 1 custom POP3 account (my.inbox.com). Everything was kosher. I then configured 1 custom IMAP account (pro30.abac.com).

    It instantly broke the ability of the iPhone to send replies to any emails in any of the configured mailboxes.

    The moment I deleted the IMAP account, the functionality began working.

    So I configured the mailbox using a POP3 server configuration. And it worked!!

    Just to make sure, I deleted it and put back the IMAP configuration. Sure enough, the problem came back.

    So while I have a workaround, I don't know what the actual problem is or why it occurs.
     
  10. AlecMyrddyn macrumors 6502

    Joined:
    Dec 5, 2008
    Location:
    Southern Maine
    #10
    First of all, excellent troubleshooting methodology! I'm guessing you've worked in tech-support or some other technical problem-solving field? :)

    As for the problem... Wow, that's just weird. If I owned an iPhone, I'd test to see if I could duplicate. But I'm still waiting to reach 18 months into my contract before I can get one. Perhaps someone else can test this on their phone.

    Definitely sounds worth reporting to Apple.

    Glad you figured it out.
     

Share This Page