Cannot restore from backup, iTunes says software too old

Discussion in 'Jailbreaks and iOS Hacks' started by thundermustard, Mar 30, 2012.

  1. thundermustard macrumors regular

    Joined:
    Apr 21, 2008
    #1
    OK, I am currently at 5.0.1 on an iPhone 4.
    My iPhone was acting up so knowing I had all my blobs and tickets, I did a restore back to a clean 5.0.1 state.
    But iTunes won't let me restore my backup, says my software is too old.
    So I got out the old Google machine and found some work arounds, but no luck.
    They mention using redsn0w 0.9.6b6 and SAM, but that is too old of a version of redsn0w to work with firmware 5.0.1
    Now I could just set it up as a new iPhone but I would rather not go through all that.
    Anyone know how to get past this?
     
  2. thundermustard thread starter macrumors regular

    Joined:
    Apr 21, 2008
    #2
    Kept looking and I found my fix, I will leave the post here for others.
    This is for an iPad 2 on Windows but you do the same thing on Mac OS X. The file is in a different place but jailbreakers are smart enough to figure that out.
    I changed these two lines to these values.

    <key>Product Version</key> <string>5.0.1</string>

    <key>Build Version</key> <string>9A406</string>

    http://www.iphoneforums.net/forum/s...-2-firmware-too-old-restore-backup-fix-30383/
     
  3. MastahRiz macrumors 6502

    Joined:
    Aug 7, 2010
  4. thundermustard thread starter macrumors regular

    Joined:
    Apr 21, 2008
    #4
    I wonder if it had anything to do with the fact that I had used the trick to get iPhoto on your iPhone or if would happen to anyone now as a way to force you to upgrade to 5.1.
     

Share This Page