Cannot restore iPod Touch?

Discussion in 'iPod touch' started by danstheman7, Nov 9, 2010.

  1. danstheman7 macrumors newbie

    Joined:
    Nov 9, 2010
    #1
    I'm trying to restore my 2G iPod touch, after the settings app stopped working randomly. I click restore in iTunes, and the restore pauses RIGHT before the completion bar ends. It never progresses, and I've left it for hours, to no avail. This iPod is running iOS 4.1, jailbroken.

    The only reason I want to restore is because it seems to be stuck in recovery mode. I've tried TinyUmbrella to kick it out, but it only seems to reboot, then get stuck in recovery mode again. I've also put my iPod in DFU mode trying to restore it, still no luck. I've even downloaded a secondary copy of iOS 4.1 and tried restoring to that through itunes, with no luck.

    I'm totally out of ideas-- any help?

    This is my first time on these forums, so I appreciate anything you have to offer me.

    Regards,
    Dan :)
     
  2. johnoporritt macrumors member

    Joined:
    Nov 9, 2010
    #2
    I had the same problem. but then i realised that i didnt have the latest version of itunes. update your itunes and it should work.
     
  3. ermoore macrumors newbie

    Joined:
    Sep 24, 2010
    #3
    Are you trying to restore to a jailbroken 4.1 or the retail copy?

    Also, have you ever changed your hosts file to direct itunes to Saurik's SHSH server?

    I did that once when I was trying to restore to a retail copy of 4.1 and it wasn't signing because I had Sauriks Server in my hosts file.
     
  4. fabian9 macrumors 65816

    fabian9

    Joined:
    Nov 28, 2007
    Location:
    Bristol, UK
    #4
    Have you had WiFi-Sync installed in the past? Or changed your hosts file either directly or through TinyUmbrella?
     

Share This Page