Cannot see Bootcamp partition after moving HDD

Discussion in 'Windows, Linux & Others on the Mac' started by pahlot, Jun 8, 2013.

  1. pahlot macrumors newbie

    Joined:
    Jun 8, 2013
    #1
    I've recently had my MacBook Pros battery die and unfortunately I am unable to boot it, or if I can get it to boot it will shut its self off without warning after a few minutes, so while I'm waiting for a new battery I bought myself an iMac.

    Now I was running VMWare Fusion and Windows 7 on my MBP and had the VM on Bootcamp.

    I removed the drive from the MBP and plugged it in to an external chassis to get my data off it. The Mac data came across without a hitch, however the Bootcamp partition does not show up in disk utility, the mac partition just shows up and the other half is blank.

    Further diagnostics give me the same output.

    PHP:
    iskutil list disk1
    /dev/disk1
       
    #:                       TYPE NAME                    SIZE       IDENTIFIER
       
    0:      GUID_partition_scheme                        *500.1 GB   disk1
       1
    :                        EFI                         209.7 MB   disk1s1
       2
    :                  Apple_HFS Macintosh HD            249.5 GB   disk1s2
       3
    :                 Apple_Boot Recovery HD             650.0 MB   disk1s3


    diskutil info disk1
       Device Identifier
    :        disk1
       Device Node
    :              /dev/disk1
       Part of Whole
    :            disk1
       Device 
    Media Name:      WD Ext HDD 1021 Media

       Volume Name
    :              Not applicable (no file system)

       
    Mounted:                  Not applicable (no file system)

       
    File System:              None

       Content 
    (IOContent):      GUID_partition_scheme
       OS Can Be Installed
    :      No
       Media Type
    :               Generic
       Protocol
    :                 USB
       SMART Status
    :             Not Supported

       Total Size
    :               500.1 GB (500105740288 Bytes) (exactly 976769024 512-Byte-Blocks)
       
    Volume Free Space:        Not applicable (no file system)
       
    Device Block Size:        512 Bytes

       Read
    -Only Media:          No
       Read
    -Only Volume:         Not applicable (no file system)
       
    Ejectable:                Yes

       Whole
    :                    Yes
       Internal
    :                 No
       OS 9 Drivers
    :             No
       Low Level Format
    :         Not supported
    I purchased WinClone in hope to get it that way but it also cannot see it. I uninstalled all NTFS drivers and have been in contact with Russel from WinClone to try to diagnose the problem. He has gone above and beyond trying to help me with this issue but unfortunately I'm no closer to finding a solution.

    I managed to get my MBP booted for long enough to access the VM and it appears that the partition is OK, but for some reason I cannot access it when its connected to the external chassis. The MBP won't stay switched on long enough for me to get a backup going :(

    After doing some more digging I've tried some different tools and they can see the partition, but I am still no closer to accessing my data :(

    Code:
    sudo fdisk /dev/disk1
    Disk: /dev/disk1	geometry: 60801/255/63 [976769024 sectors]
    Signature: 0xAA55
             Starting       Ending
     #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
    ------------------------------------------------------------------------
     1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
     2: AF 1023 254  63 - 1023 254  63 [    409640 -  487368880] HFS+        
     3: AB 1023 254  63 - 1023 254  63 [ 487778520 -    1269544] Darwin Boot 
    *4: 07 1023 254  63 - 1023 254  63 [ 489048064 -  487725056] HPFS/QNX/AUX
    
    estDisk 6.14-WIP, Data Recovery Utility, May 2013
    Christophe GRENIER <grenier@cgsecurity.org>
    http://www.cgsecurity.org
    
    Disk /dev/disk1 - 500 GB / 465 GiB - 976769024 sectors (RO)
    Current partition structure:
         Partition                  Start        End    Size in sectors
    
     1 P EFI System                    40     409639     409600 [EFI system partitio
     2 P Mac HFS                   409640  487778519  487368880 [Customer]
     3 P Mac Boot               487778520  489048063    1269544 [Recovery HD]
    Warning: number of heads/cylinder mismatches 255 (NTFS) != 1 (HD)
    Warning: number of sectors per track mismatches 63 (NTFS) != 1 (HD)
     4 P MS Data                489048064  976773119  487725056 [BOOTCAMP] [BOOTCAMP
    ]
    
    
    I'm hoping that someone out there might know why my MBP running Mountain Lion could see the partition, but my iMac running ML as well cannot see it when it is attached to an external USB connection. Or maybe someone can at least point me in the right direction to get access to my partition.

    I am a bit reluctant to mess with the partition as it still appears to work on the MBP...

    Thanks in advance.
     
  2. Mansell5 macrumors newbie

    Joined:
    Aug 7, 2013
    #2
    I'm probably 2 months late, but have you tried ReFit? I had the same issue as you and solved if using their partition tool. One additional thing I did was to use Gparted to delete a random Fat32 partition that was causing some confusion.

    After using Refit you may need to use Startup Repair from your original win7 installation DVD.
     

Share This Page