Cannot See data restored from Time Machine

Discussion in 'macOS' started by iamthereforipad, Jul 22, 2011.

  1. iamthereforipad macrumors newbie

    Joined:
    Jul 22, 2011
    #1
    I had to backup my iMac (mid-2011) to Time machine prior to a rebuild. My external HD was the same (500GB) size as my internal disk; therefore, I could not do a complete backup because it was larger than 500GB.

    So I backed up everything minus the system files.

    After I erased the disk and installed the OS, I used Time Machine to restore my data. It took 4 hours, and consumed the disk space; however, the data cannot be seen from the OS (latest version).

    It appears that the new disk is called Macintosh HD 1 although the Finder sees it as Macintosh HD. Macintosh HD 1 is a symbolic link to the top level directory "/". The original disk was called Macintosh HD (without the number 1).

    The data was restored to Macintosh HD instead of this Macintosh HD 1 volume. In Terminal I can see that Macintosh HD and Macintosh HD 1 are both in the /Volumes directory. Macintosh HD is a real directory that contains the restored data. Macintosh HD 1 is a symbolic link that points to /.

    I tried moving the data in Terminal to the proper place; however, it only moved the data that didn't exist and indicated that I don NOT have permissions to over right anything that exists (I tried moving the Applications directory).

    Does anyone have a solution for this?
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    Is it setup as the same username as the previous Mac?
     
  3. iamthereforipad thread starter macrumors newbie

    Joined:
    Jul 22, 2011
    #3
    Yes, it created the user "carl" during the setup.

    The new installed created the main disk as Macintosh HD, but to the OS, the volume is a symbolic link the the root level directory. So if I open terminal and
    type cd /Volumes and type ls - lsa to see what the disks are, I see 3 items.: The Time Machine volume, Macintoch HD and Macintosh HD 1.

    So I look inside /Volumes/Macintoch HD/ I see all of the restored data.
    If I look at Macintoch HD 1, it is a link to / instead of being a directory called /Volumes/Macintosh HD 1/. I see Macintosh HD 1 in the list of Volumes if I hold down the Option button on a system startup.

    The Time Machine is not restoring the data to Macintosh HD 1, but to Macintosh HD and is therefore not seen by the OS.
     
  4. iamthereforipad thread starter macrumors newbie

    Joined:
    Jul 22, 2011
    #4
    Using the Migration Assistant worked.
     

Share This Page