Cannot see external hard drive

Discussion in 'Mac Basics and Help' started by libbymcm, Jan 13, 2008.

  1. libbymcm macrumors newbie

    Joined:
    Jan 13, 2008
    #1
    I have loaded Leopard on to my G4 and all is functioning well - and I am using the Time Machine facility too. However, I have tried to connect another hard drive as an additional backup to leave at my home base - and I cannot see it in the directory and therefore cannot use it. I had disconnected the first external hard drive first before I tried to connect the 2nd one. I have turned the computer on and off and still there is no recognition of this second external hard drive. I am connecting it to the USB port. I hope that someone can assist me with this - I cannot work it out! Thanks - in anticipation.
     
  2. johnmcole macrumors newbie

    Joined:
    Jan 17, 2008
    #2
    I am having a similar problem with my system recognizing and mounting USB drives since upgrading to Leopard.

    I'm running a newer Mac Pro with 10.5.1 and cannot seem to get any of the USB ports on the CPU itself to recognize either my external hard drive or my 1gb USB flash drive.

    However, when connecting the USB flash drive to the extra port on the Apple keyboard, it is recognized and mounted. It is not recognized when going directly in any of the ports on the front or back of the machine.

    This used to work and appears to have stopped some time around the Leopard upgrade. I was running Time Machine and I'm thinking that may have somehow been related.
     
  3. buffie macrumors newbie

    Joined:
    Jan 6, 2008
    #3
    I have been using my Macbook Pro (brand new with Leopard factory installed) for about 8 weeks and haven't had any trouble with it recognizing my external hard drives until a few minutes ago. I'm in a real bind with a deadline and no way to print what I've been working
    on for a deadline (I'm also having trouble getting any of my printers to work
    with this computer).
    Can anyone help?????
     
  4. johnmcole macrumors newbie

    Joined:
    Jan 17, 2008
    #4
    Are you current with all of the latest updates? I'm pretty sure one of the recent OS X updates fixed the issue for me, but I'm not positive.

    I also installed a powered USB hub and I'm running my external to my Mac Pro through it. I haven't had any USB connection problems since... but need to do some more testing to determine what fixed it.

    In any case, those are the two things that I would try to get you back up and running.

    Good luck!
     

Share This Page