Cannot See ITunes from AppleTV

Discussion in 'Apple TV and Home Theater' started by thebritishguy, Apr 23, 2013.

  1. thebritishguy macrumors member

    Joined:
    Dec 30, 2011
    #1
    Hi all


    I need some help please

    I have a new iMac that has Home Sharing enabled on iTunes and yet neither one of my AppleTVs can see it when i try to access the computers option on the AppleTV.

    I also have a MBP that is connected to the same network and it works fine, ie i can connect to Itunes on the MBP fro, the iMac.

    The weird thing is that I can Airplay from the iMac to either AppleTV but cannot go the other way (connect to iTunes)

    So far I have tried

    Confirmed both computers are using the same ITunes account
    Enabled Sharing (and disabled/reenabled to try and fix)
    Tried Fixed IP and DHCP for Imac
    Tried Wired and Wireless for the iMac
    Deleted all config XMLs from Music/iTunes and had iTunes rebuild
    Authorized/De and Reauthorized iTunes on the iMac
    Called it a various amount of colorful names

    Any other ideas?

    Thanks TBG
     
  2. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #2
    Some basic troubleshooting steps here: http://support.apple.com/kb/TS2972?viewlocale=en_US

    Verify everything's up to date (latest version of ATV software and iTunes)

    It looks like you said your iMac can see the shared library on your MBP - can the MBP see the library on the iMac? If not it's likely an issue on the iMac, if the MPB sees the library but the ATV's don't then it's probably a config issue on the ATVs.
     
  3. thebritishguy thread starter macrumors member

    Joined:
    Dec 30, 2011
    #3
    Update - how to resolve

    After speaking with Apple support i took the iMac into the Apple Store today

    There seems to be a bug in iTunes on 2012/2013 iMac that prevents iTunes from authorizing home sharing over the ethernet connection, it does not report any error but fails to authorize

    To resolve this issue unplug your ethernet cable, enable a wireless connection to the internet and disable/enable home sharing in iTunes, once authorized you can then use the ethernet connection again.

    Hope this helps out other folks in the future

    TBG
     

Share This Page