Cannot Send Email when Connected via Edge

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rayward, Jul 5, 2007.

  1. rayward macrumors 68000

    Mar 13, 2007
    Houston, TX
    I can send and receive email when on Wi-Fi, and I can receive email when on EDGE, but I cannot send email when on EDGE. Is this a common problem? Anyone know how to fix it? Thanks.

    (My email is a POP3 account through Roadrunner)
  2. badtzmaru macrumors 6502

    Jul 1, 2007
    when iwas at the apple store on saturday a woman had the same problem.

    I dont know what was done to resolve it.

    but you might want to call roadrunner and see if they can help.
  3. paymaster macrumors newbie

    Apr 5, 2006
    Yes this is common. It is discussed in a few other threads. Road Runner will only accept emails when you are on it's network, like when you are at home on wi-fi. It will not send email from other providers such as Edge. This is to try and reduce spam. The only workaround I have found so far is to put in the settings that work with edge(in the Outgoing mail server the host name should be and turn off wi-fi to send email when I at home or at any hotspots using wi-fi. It stinks but the only other option right now is to have to change the settings everytime.
  4. rayward thread starter macrumors 68000

    Mar 13, 2007
    Houston, TX
    Thanks. Using worked.

    Comcast is taking over from Time-Warner/RoadRunner in my area. Anyone know if Comcast has the same rules?

    ETA: From a web search, looks like Comcast is the same.
  5. paymaster macrumors newbie

    Apr 5, 2006
    Glad to help. I am pretty sure almost all ISP's are the same way. Apple/AT&T are going to have to come up with some sort of solution or there are going to be a lot of upset people, and they can forget about selling these to business. Below is what Road Runner had to say about this.

    "I appreciate you taking the time to provide feedback regarding
    connectivity to Road Runner email through the IPhone device. Road Runner
    implements security features which prevent the use of SMTP relays
    (forwarding email from a different network through Road Runner SMTP
    servers). As open relays are one of the main sources for the
    distribution of unsolicited email, efforts are made to prevent as much
    as possible the distribution of such through the Road Runner network. We
    do provide remote access to Road Runner email through our webmail
    interface which can be accessed through a web browser from any
    connection to the Internet. Email can be received and sent through the
    webmail interface. It is also possible to configure email forwarding
    through the webmail interface should you wish to have your email
    forwarded to an alternate email address.

    It may also be possible to configure your mobile device to use the Road
    Runner POP3 server for inbound email and use an alternate SMTP server on
    the network to which you are connected for outbound email. SMTP server
    information can generally be obtained from the network service provider
    you are utilizing for your mobile device. "
  6. marksman macrumors 603


    Jun 4, 2007
    I would advise getting your own mail account or else finding a service that allows password authentication for sending mail.

    That way you only need to use one account to send mail regardless of how you are connected.
  7. sundevil67 macrumors newbie

    Dec 15, 2005
    Outgoing Mail Servers

    I am having a similar problem as I cannot send outgoing mail from two out of three of my IMAP email accounts. I don't think it is a limitation with my Cox ISP because I can use my .Mac outgoing server just fine. Neither of these accounts work with Mail on my computer either since upgrading to Leopard.

    Any ideas?

  8. amemoryoncelost macrumors 6502

    Jun 14, 2004
    I've been having the same issues with gmail lately, very weird...
  9. mvirgili macrumors newbie

    Nov 25, 2007
    Cannot send email on iphone

    I have tried everything and cannot send email on my iphone. It worked when I first set my phone up with my settings from Exchange Server, but now I have tried using, my own isp, etc. and I have even altered ports, nothing works. I have tried turning off Wifi and just using Edge. I am very frustrated. I use Exchange Server at work, and my email is received just fine. Please help.
  10. rxl125 macrumors regular

    Apr 15, 2006

Share This Page