Cannot send mail (message was rejected)

Discussion in 'iOS 11' started by d4vex, Aug 8, 2017.

  1. d4vex macrumors newbie

    Joined:
    Jun 8, 2017
    #1
    I'm not able to send reply to mail via our company exchange server 2016 activesync, new emails work just fine. My second device is on ios 10 where this works with same emails which i'm not able reply to on ios11. This begun with beta 1 but now on beta 5 it seems, that something changed in activesync and exchange 2016 does not like it.
     
  2. daflake macrumors 6502a

    Joined:
    Apr 8, 2008
    #2
    It may have... If you are looking for a solution, prepare for the "roll your device back" as well as the "stay off beta for production devices" comments. ;)

    What version of Exchange is your company running?
     
  3. d4vex thread starter macrumors newbie

    Joined:
    Jun 8, 2017
    #3
    Question is if somebody has the same problem or if this is just our mail server. As this begun with beta 1 i was waiting with searching for a solution, but now with beta 5 it seems its not a bug.

    And as mentioned earlier exchange 2016.
     
  4. daflake macrumors 6502a

    Joined:
    Apr 8, 2008
    #4
    Sorry, been a long morning here. I didn't notice you had said it.

    That is a good question. We don't allow Beta on our devices, but it might be worth loading for testing before it gets deployed. We also have 2016 here. I will say that it could also be that they are still developing on it and that it will be fixed before it goes out to production.

    Have you filed a bug report?
     
  5. d4vex thread starter macrumors newbie

    Joined:
    Jun 8, 2017
    #5
    Yes i did.

    I hope it gonna be fixed, but better to be prepared ;) Anyway i got chance to add another exchange 2016 to the phone and results are the same. So it seems there are some changes in activesync protocol which exchange 2016 doesn't like. Exchange 2010 works fine with all betas.
     
  6. Nhott macrumors member

    Joined:
    Aug 5, 2014
    #6
    Mine has done that from time to time on. A reboot has always fixed it for me.
     
  7. d4vex thread starter macrumors newbie

    Joined:
    Jun 8, 2017
    #7
    Even with the GM version the issue still exists. Can't sent e-mails with attachments or photos inserted.
     
  8. BlackEyedNL macrumors newbie

    Joined:
    Jun 22, 2017
    #8
    Same probleem here (on GM, Office 365). From time to time message is rejected. Reboot solves this but returns for no apparent reason.
     
  9. RabidMacFan macrumors regular

    Joined:
    Jun 19, 2012
    Location:
    California
    #9
    I had this problem a few times after installing iOS 11. The message end up in the mail "Outbox". I go there and try to send it again and it goes through.
     
  10. sguser macrumors regular

    Joined:
    Aug 12, 2010
    #10
    Same problem in both iPhone and iPad on the GM seed build. No need to reboot, just go to the Outbox, open a message and click Send. It might not work on the first try, but eventually it does.
     
  11. BlackEyedNL macrumors newbie

    Joined:
    Jun 22, 2017
    #11
    Thanks for your tip. However I already tried this, sometimes up until ten times and it still would not send.
     
  12. Nhott macrumors member

    Joined:
    Aug 5, 2014
    #12
    I had that happen a couple of days ago. I can usually send it from the outbox but for whatever reason it would not. Tried a reboot, still wouldn’t send. Out of frustration I went to the outbox and sent it from my personal email.
     
  13. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #13
    This is the only other discussion about it I could find:

    https://forums.developer.apple.com/thread/79446

    This is going to be a disaster for enterprise when they start rolling out iOS 11 to production devices. My mind is absolutely blown that this issue exists in the GM build.
    --- Post Merged, Sep 18, 2017 ---
    I have logged this bug with Apple and will let you guys know what happens.
     
  14. pesos macrumors 6502a

    pesos

    Joined:
    Mar 30, 2006
    #14
    susbscribe. seeing this problem in our environment as well. raising it with the Exchange team.
     
  15. pesos macrumors 6502a

    pesos

    Joined:
    Mar 30, 2006
    #15
  16. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #16
  17. pesos macrumors 6502a

    pesos

    Joined:
    Mar 30, 2006
    #17
    Sadly no, you'll have to wait for a client side fix from Apple, or use the Outlook for iOS app.
     
  18. Marshall73 macrumors 6502a

    Marshall73

    Joined:
    Apr 20, 2015
    #18
    I resolved this by going into account settings and reentering the password. Not had any issues on the 3 exchange accounts I use since doing that.
     
  19. Reno Raines macrumors 6502a

    Joined:
    Jul 19, 2015
    #19

    This is happening with me as well on the GM build. I have to try multiple times to get my email through on iOS 11. My other phone is on iOS 10 and no issues.
     
  20. Knightcastle macrumors 6502

    Knightcastle

    Joined:
    Apr 25, 2015
    #20
    This is an issue for me on WiFi but not celluar
     
  21. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #21
    Apple have responded!

    https://support.apple.com/en-us/HT208136

    If you can‘t send an email with iOS 11 and an Outlook.com or Exchange mail account

    You might see an error message that says "Cannot Send Mail. The message was rejected by the server."


    If your email account is hosted by Microsoft on Outlook.com or Office 365, or an Exchange Server 2016 CU3 running on Windows Server 2016, you might see this error message when you try to send an email with iOS 11: "Cannot Send Mail. The message was rejected by the server."

    Apple is working closely with Microsoft to resolve the issue and will release a fix soon in an upcoming software update.
     
  22. mrthomnas macrumors regular

    Joined:
    Sep 8, 2014
    #22
    How'd you find that support article?
     
  23. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #23
    Well it was just posted a few minutes ago.
     
  24. pesos macrumors 6502a

    pesos

    Joined:
    Mar 30, 2006
    #24
    The Exchange team is also taking steps to mitigate this issue in O365 while a proper fix from apple is forthcoming.
     
  25. StuBFrost macrumors member

    Joined:
    Apr 1, 2016
    Location:
    Manchester, England
    #25
    Just about to update but this is a showstopper for me and absolutely ridiculous that it takes to release day to get acknowledged by Apple.
     

Share This Page