Cannot Send Mail - The sender address was invalid?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ballen420, Jul 25, 2008.

  1. ballen420 macrumors 6502

    Joined:
    Mar 21, 2008
    Location:
    South of Boston
    #1
    Lately, every time I try to reply to an email, or initiate an email, I am getting the following error message:

    Cannot Send Mail - The sender address was invalid

    Anyone else have this issue and know how to fix it? The addresses are all legit. I'm using a Comcast Pop email account.

    Thanks in advance.

    Brian
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    The sender address is your email address, it's stored in the email settings on the phone. Has this got corrupted so that the Comcast server does not recognise it? Check in Settings.
     
  3. ballen420 thread starter macrumors 6502

    Joined:
    Mar 21, 2008
    Location:
    South of Boston
    #3
    So that's what sender means! D'oh. Too early in the morning still.

    I don't see any issues with the setup in my settings. Everything appears as I believe it should.

    Anything specific I need to do with Comcast? Or anything change recently?

    I didn't have this issue with my old iPhone. And I have no issues receiving email.
     
  4. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #4
  5. timhalv macrumors newbie

    Joined:
    Mar 4, 2010
    #5
    I tried to get the right information for quite a while. I finally tried the following, and it worked:

    Having AT&T, Go to the affected account, and change the outgoing smtp and change it to cwmx.com . I previously had it as smtp.cwmx.com and that seems to not work anymore. If you take out the smtp. that should work.
     

Share This Page