Cannot setup preinstalled mac mini server

Discussion in 'Mac OS X Server, Xserve, and Networking' started by afiglee, Dec 1, 2010.

  1. afiglee macrumors newbie

    Dec 1, 2010
    Hello, folks!
    This is my first post. :)

    Not too much reason to smile...
    Well, I just bought mac mini server from Apple - 2.66 GHz processor, 2 hard drives 500 G and preinstalled Mac OS X Snow Leopard Server..

    So, I'm trying to set it up - turned it on, appeared white screen with apple, then flying "X", then "Welcome Screen" with 2 buttons - "Go back" and "Continue". Buttons are disabled.
    And never enabled. In the left bottom corner I have running indicator which supposedly telling that it is trying to get info from the network.
    First time I tried - I did not have my DHCP server enabled, second time I removed ethernet cable - no luck, now instead of Welcome screen I got image of a paper, few shapes indicating some device and green led blinking on that "device". My guess is it is trying to tell me that it wants to use wireless network.
    Unfortunatelly, I do not have airport access point..
    So, every second time after restart I got either - this "device on paper", or
    a "Welcome screen" - never can get pass those two.
    So, I think it tries to connect to internet.
    I have enabled DHCP, and saw that mac mini leased address, I can ping this IP from other machine, but after 30 minutes of waiting - no progress.

    Any ideas?
  2. Transporteur macrumors 68030

    Nov 30, 2008
    You don't need an internet connection to set it up. The setup assistant asks for network settings (wired or wireless) later, but you skip that.

    So your internet is not the issue here. It seems as if you've a problem with the drives. Can you boot from DVD and check the disc utility if both drives appear?
  3. afiglee thread starter macrumors newbie

    Dec 1, 2010
    Are you sure this is valid for Server version? I have read that it verifies serial number over the internet, and when I called Apple support yesterday, they confirmed, that internet connection must be available.
    I arranged DHCP server on my FreeBSD box and will try to sniff it with tcpdump.
    Meanwhile will try your idea as well.
    The problem is that mac mini does not come with DVD player, I have to attach external.
    Documentation says I can use fire-wire player, which I do not have, will try my external USB LiteOn, hopefully will work and check drives..
  4. happyslayer macrumors 6502a


    Feb 3, 2008
    Glendale, AZ
    The Mac Mini server may require the MacBook Air Superdrive. I had to use that when I set one up for a client. Luckily I have an Air so I had an Air superdrive.

    Good Luck.
  5. blacka4 macrumors 6502

    Sep 28, 2009
    this is going to sound stupid but you do have a keyboard and mouse plugged in?
  6. afiglee thread starter macrumors newbie

    Dec 1, 2010
    actually, it does not. Yes, I do have. And monitor connect through HDMI.

    I cannot play with it today, but tomorrow will try all sugestions, including connecting CDROM player.
    I did shared one on other machine, as documentation suggested, but had no luck. Will try it localy.

    Thank you all for the suggestions.
  7. Transporteur macrumors 68030

    Nov 30, 2008
    I just installed my Server version in a VM again and even without a network connection, it worked just fine till the point of entering the serial (unfortunately my serial isn't valid any more so I can't continue).
  8. afiglee thread starter macrumors newbie

    Dec 1, 2010
    Well, that is sad... No luck.
    Anyway - I start from the begining.
    First I tried my dhcp, looked up at tcpdump - see some packets going to and so on - at some point stopped, no luck.
    Then I added USB CDROM, rebooted, mac mini did not recognized it, I rebooted with pressed "alt" (option) key - appears selection between hard drive and dvd, I choose dvd, rest is the same as before.
    Next time I rebooted with "D" pressed, appears diagnostics, run - everything in green checkboxes.
    Tried to run admin tools from CD - no luck either, does not offer any choice, just boot from hard drive.
    Tried with DVD on my mac under virtual machine, shared dvd drive, went to target server, booted with option key, found my shared drive, offered to boot from it, successfully communicated, I saw the link, both are working, stuck at the same place.

    Call Apple, they said bring to Apple store.. I think they will replace it eventually..

    Here is the picture I'm getting exactly every second reboot - what would that mean?

  9. malachiman macrumors regular

    Sep 18, 2008
    New Zealand
    Its telling you to turn your magic mouse on. I got this the first time I started up a Mac Mini, even though I had a USB mouse connected. After several seconds it was fine.
  10. RedAntArmy macrumors newbie

    Mar 6, 2009
  11. afiglee thread starter macrumors newbie

    Dec 1, 2010
    Thank you everyone.
    No magic.
    After visiting Genius Bar at Apple store unit has been declared defective and ordered to send back to Apple.
    Hope to have it back in a week - 10 days. :)
  12. SVT Amateur macrumors 6502

    Dec 22, 2006
    Tyler, Texas
    You are in the same place I was 3 weeks ago, lol. I didn't have a Magic Mouse but had the Apple Wireless Trackpad but since 10.6.3 doesn't recognize the trackpad (at least until you install it) I couldn't get past that screen either. I had to go buy a wireless mouse ($20 Dynex one) just to be able to get setup to run.
  13. afiglee thread starter macrumors newbie

    Dec 1, 2010
    Hmm.. Interesting.. Why did not you use any generic mouse? It should work.
    And - folks at Genius Bar tried to install using apple's mouse and keyboard and could not..

    But this is valuable info. Thank you very much
  14. logandzwon macrumors 6502a

    Jan 9, 2007
    I was gonna say... it sounds defective... the behavior you were reporting is not standard for OS X Server.
  15. afiglee thread starter macrumors newbie

    Dec 1, 2010
    Received new unit. Installation was a breeze, so the previous unit indeed was defective.

    The "Welcome screen", where I previously choked, now showed list of locations to choose from - "Canada, USA,.."

    Yahoo... :)

    P.S. No internet connection required, nor DVD disk - installed from preinstalled image

Share This Page