Cannot SMB to XP machine

Discussion in 'Mac OS X Server, Xserve, and Networking' started by drennan, Dec 11, 2008.

  1. drennan macrumors member

    Joined:
    Jun 25, 2007
    Location:
    London
    #1
    Hi. I've just networked my Mac laptop and PC through a wireless router. They both connect to the internet with no problems and i can ping between machines. I need to access the PC hard drive from the mac but I cant connect and am getting the following error "Sorry, the operation could not be completed because an unexpected error occurred (Error code -50)". I've followed the steps at http://guides.macrumors.com/Networking_Windows_with_Mac_OS_X. I have also googled this and tried everything i can find but still no luck. I've added 'local' to 'search domains' in network prefs (as per apple website) and tried the following steps from a forum but am still getting the error message.

    step 1 : download smbfs.kext.zip
    step 2 : open terminal (located in applications / utilities)
    step 3 : sudo -s (then enter root password)
    step 4 : rm -R /System/Library/Extensions/smbfs.kext
    step 5 : cd /Users/yourusername/Desktop
    step 6 : unzip smbfs.kext.zip
    step 7 : cp -R smbfs.kext /System/Library/Extensions/
    step 8 : rm -R /System/Library/Extensions.mkext
    step 9 : rm -R /System/Library/Extensions.kextcache
    step 10 : chmod -R 755 /System/Library/Extensions/smbfs.kext
    step 11 : chown -R root:wheel /System/Library/Extensions/smbfs.kext
    step 12 : shutdown -r now

    When I SMB, it does connect to the XP machine and accepts my windows password and gives a list of available drives but the error message pops up as soon as i select a drive. So it looks like comms is working but it just wont let me access the drive. Any help would be appreciated as i've spent lots of time over the last few weeks trying to get these machines to talk through wireless and am almost there! Thanks guys, Dren.

    EDIT: Or is there an alternative to SMB, i.e. running an FTP server on the PC and accessing the directories over the LAN, or something similar?
     
  2. drennan thread starter macrumors member

    Joined:
    Jun 25, 2007
    Location:
    London
    #2
    I got it working!! I downloaded some software called 'dave'. I disabled SMB in sharing prefs and its all working at last! Hope this helps someone else. Not a fix as such but at least I can access my files now. Dren
     

Share This Page