Resolved Cannot stop -- auto-replace

Discussion in 'iOS 11' started by AlecEdworthy, Sep 19, 2017.

  1. AlecEdworthy macrumors 6502

    AlecEdworthy

    Joined:
    May 1, 2007
    Location:
    Leicestershire, UK
    #1
    Since installing iOS 11 I am finding my iPhone (OTA update this evening) and iPad (clean install of the GM last week) are replacing -- (dash dash) with what I think is an em dash (—). I've tried creating a Text Replacement to map -- to -- in an attempt to trick it but that has not worked. Anyone else noted this? Anyone know how to stop it please? As a user of *nix I find -- very useful to be able to type in messages.

    Thanks in advance, Alec
     
  2. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #2
    Have you tried changing some keyboard settings, like the one at Settings > General > Keyboards > Smart Punctuation
     
  3. AlecEdworthy thread starter macrumors 6502

    AlecEdworthy

    Joined:
    May 1, 2007
    Location:
    Leicestershire, UK
    #3
    Grrrr, thought I'd tried that but clearly not. Also thought it was "Smart quotes" not "Smart punctuation". I suppose for 95% of users an auto replace of -- with an em dash is smart punctuation, however as a *nix user it's not quite so smart.

    Thanks @C DM, sorry you had to point that out to me :(
     
  4. Feenician macrumors 601

    Feenician

    Joined:
    Jun 13, 2016
    #4
    If you happen to be using a hardware keyboard, ALT + –– leads to what you see here. They’re slightly longer dashes (the name escapes me) but should fit your purpose I think?

    If you’re not @C DM’s suggestion seems a good start.
    --- Post Merged, Sep 19, 2017 ---
    Update: If you are using the software keyboard a long press on the dash key and selecting the short dash also prevents the auto “correction” :p It’s obviously relatively slow though.

    Edit: Welp, I’m too slow :oops:
     

Share This Page

3 September 19, 2017