cannot subscribe to podcasts in itunes 7.5

Discussion in 'Mac Apps and Mac App Store' started by dazed, Jan 2, 2008.

  1. dazed macrumors 6502a

    Joined:
    Jun 23, 2007
    #1
    Hi,

    I cant seem to subscribe to any podcasts in itunes. all the subscribe buttons are greyed out.

    Im new to mac and this is the first time ive tried so maybe im doing something wrong.

    I have a mac mini with leopard and the latest version of itunes.

    I tried to log into the store but it asks for my credit card which i don't want to give. could this be the problem ?
     
  2. dastardlymut13 macrumors newbie

    Joined:
    Mar 27, 2008
    #2
    Try This...

    As stupid as it sounds, there may be a really easy way to fix this problem.
    click edit, then preferences.

    In preferences, click on the Podcasts button and read what it says...
    A) if it says "check for new episodes" I can't help you, BUT
    B) if it says..."Podcasts are disabled due to Parental Controls" then
    click on the parental controls tab and unclick the "disable podcasts" check-box.

    This happened to me in my itunes, and I had never even opened the parental controls.
     
  3. mperkins37 macrumors 6502a

    mperkins37

    Joined:
    Jan 17, 2007
    Location:
    Phoenix, AZ
    #3
    Yeah, what he said, It's more than likely our preferences settings.
     
  4. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #4
    Hi,

    don't mean to be a smarta** here, but the latest version of iTunes is 7.6.1 not 7.5

    Maybe you do an update, if the problem is persistent.

    /Rupert
     
  5. callmemike20 macrumors 6502a

    callmemike20

    Joined:
    Aug 21, 2007
    Location:
    USA
    #5
    Well, at the time of this posting, the current iTunes version was 7.5. So, I wonder who decided to bring such an old thread back to the top. Mods, please lock this as it is now irrelevant.
     
  6. goSegway macrumors newbie

    Joined:
    Sep 27, 2010
    #6
    no podcast folder in iTunes 10

    :confused:Seriously . . . this is still an issue in itunes 10. And yes, the fix (for me) was to edit the parental controls. What a joke . . . the programmers must be getting too much koolaid in the cafeteria! :p
     

Share This Page