Cannot sync any photos from iTunes to iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cocoatronik, Jan 10, 2014.

  1. cocoatronik, Jan 10, 2014
    Last edited: Jan 14, 2014

    cocoatronik macrumors member

    cocoatronik

    Joined:
    Sep 13, 2008
    Location:
    Minneapolis, MN
    #1
    Hello, I need some help.

    PROBLEM DETAILS:

    I cannot sync any photos from iPhoto to my iPhone. When I select the box to "Sync Photos from iPhoto," it displays "0 photos" regardless of what other settings I try (all photos, selected albums, etc.).

    (Edit: As noted below, I've found I can sync "All photos" once I free up enough space on the device. The issue appears to be with selecting iPhoto albums, faces, events, etc.)

    I can sync photos from folders other than iPhoto. Also, I can import photos from my iPhone into iPhoto. The problem seems limited to syncing from iPhoto to my iPhone.

    This started when I was having problems syncing only a few photos. After trying to create duplicate versions, I followed the steps for removing the iPod Photo Cache. (I have had that issue in the past, and this same process resolved it then.) It was after this process that no photos would sync. This issue does not coincide with any hardware or software upgrades.

    The iPhone appears to have about 2 GB of free space, and I am working with about 300 MB of photos. (I have tried syncing a single photo, and that also failed, so I don't think it's a storage issue.)

    WHAT I'VE TRIED:

    I have tried removing the iPod Photo Cache. (First by syncing the iPhone with no photos selected, then unplugging the phone, closing iTunes and iPhoto, trashing the iPod Photo Cache folder, emptying the trash, rebooting the iMac, restarting the phone, reattaching the phone, and then trying to sync again.)

    In iPhoto, I opened with option+command to repair permissions, repair the database, and even rebuild the database. (Rebuilding eliminated all photo ordering in my albums.)

    Since the problem appeared to be with iTunes recognizing photos in iPhoto (showing "0 photos" regardless of what is selected), I tried restoring my entire iPhoto Library from Time Machine, reverting to a version when syncing photos still worked (prior to deleting the iPod Photo Cache).

    I have also repaired permissions on my entire iMac drive.

    I do not use Aperture, but I also tried deleting the ApertureDatabaseTimestamp file under iLifeSharing.

    I've tried searching the internet for a solution, but have only found threads going off in multiple directions with no clear advice.

    HARDWARE AND SOFTWARE:

    • iMac (mid-2011) running OS X 10.9.1
    • iPhoto 9.5.1
    • iPhone 4S running iOS 7.0.4
     
  2. mKTank macrumors 68000

    mKTank

    Joined:
    Jul 2, 2010
    #2
    Could try using iPhoto without iTunes in the middle. Maybe try completely reinstalling iPhoto?
     
  3. cocoatronik, Jan 12, 2014
    Last edited: Jan 12, 2014

    cocoatronik thread starter macrumors member

    cocoatronik

    Joined:
    Sep 13, 2008
    Location:
    Minneapolis, MN
    #3
    Thank you for the suggestion, but could you expand on that? I have not found any way to move photos from iPhoto to a connected device.

    ----------

    Additional information:

    I tried deleting com.apple.iTunes.plist from User\Library\Preferences, but this had no effect.

    In an effort to "reset" what I suspect to be a corrupt database somewhere, I freed about 5.5 GB on my iPhone and attempted to sync all photos from iPhoto instead of just selected albums. This appeared to work more or less. After syncing all photos, the orange portion of the storage indicator bar in iTunes displays "1.54 GB, 3758 Photos." This figure is actually 869 photos short of "all" photos in iPhoto. I don't know whether this might be significant, but 869 is a reasonable estimate of how many photos were previously on the iPhone when this problem started.

    I then unchecked the "Sync Photos" checkbox, and iTunes asked me to confirm deleting photos from the device. I said yes. This also appeared to work, and my iPhone is back to zero photos. However, I am still unable to sync anything from selected albums, events, or faces.

    I also tried connecting a different device. When I connect my iPad and hover over the orange photos area of the storage graphic bar in iTunes, it shows "393.1 MB, 996 photos," which appears to correctly reflect what is on that device. When I check the box to "Sync Photos from iPhoto" with the radio button for "All photos...," that orange bar expands to "3.84 GB, 4617 Photos" (only 10 short of "all"). However, when I select the radio button for "Selected albums," then the orange bar disappears entirely, and iTunes displays "0 photos" regardless of which how many albums I select. I did not sync my iPad, because I do not want to lose photos on that device as well. But this experiment with the iPad seems to indicate the problem is not the device.
     
  4. cocoatronik, Jan 16, 2014
    Last edited: Jan 16, 2014

    cocoatronik thread starter macrumors member

    cocoatronik

    Joined:
    Sep 13, 2008
    Location:
    Minneapolis, MN
    #4
    SOLVED! :)

    I downloaded a free third-party app called iPhoto Library Manager, which was able to rebuild my iPhoto library. This restored selective photo syncing in iTunes.

    Note that I had previously tried iPhoto's own repair and rebuilding steps (using option+command on launch), but these did not solve the problem. The rebuilding performed by iPhoto Library Manager was a much lengthier process, apparently performing a more comprehensive rebuild. In fact, it creates an entirely separate library, leaving the original intact as a backup.

    The only drawback I've noticed in rebuilding with iPhoto Library Manager is that I lost my custom ordering of photos within albums.

    Note: The size of the new library is about 25% larger (about 5.1 GB compared to 3.9 GB), although I don't know why this is. Perhaps this represents what was "missing" from the corrupt library?
     
  5. smooth macrumors 6502

    smooth

    Joined:
    Nov 12, 2007
    Location:
    Detroit
    #5
    I cannot thank you enough for this post!!!!!!


    I noticed issues after Christmas when I received an Apple TV for Christmas. My photos library would not show up on it. That's when I noticed that the Photos section of iTunes would not display the number of photos at the top. I didn't care too much that it didn't work with Apple TV. I was still able to add photos and albums to my iPad (one of the main reasons I purchased an iPad) so that was all I care about.

    Right around the time of the newest iTunes update, I got a new rMBP. Everything seemed to transfer from my previous MBP just fine. I bought some songs, synced to my iPhone just fine. When I went to add a photo album, I went to the Photos section for the first time since both updating iTunes and for the first time on the new rMBP. The photos had been unchecked. I checked it, and re-selected the couple albums I kept on my phone. When I synced the phone, I got the error 50. I unchecked Photos again and it synced fine, but removed the albums. After rebuilding and repairing my iPhoto database, restoring my iPhone and a couple other "solutions" I found online, nothing worked.

    Using iPhoto Library Manager worked beautifully. Like you said, my photos were in a different order, as were my albums. It must be an OCD thing, but I HAVE to have my albums chronologically. So I went one-by-one to each album, clicked on NEW ALBUM, deleted the old one and iPhoto let me re-order my albums in any order I want as well as the photos in the album.

    Thank you again!!!!!
     

Share This Page