Cannot Sync iPhone with Itunes, Get "The iPhone is already activated."

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Dm3k1, Mar 12, 2009.

  1. Dm3k1 macrumors newbie

    Joined:
    Mar 12, 2009
    #1
    "The iPhone is already activated. You may disconnect this iPhone now" Is the message I get when I plug in my restored iPhone into the computer that just did the restore. The phone is activated, I can make calls and texts etc. However when you plug it in, itunes pops up with this message, when you press okay the iphone gets taken off iTunes. (The phone is still charging.) I have reinstalled 8.1, anyone have any other suggestions?

    Thank you VERY much.

    Danny
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    Well, you could try deleting the activation records off the phone if you are jailbroken, though I guess that advice should carry the health warning that I have never done it so I don't know if it would crash your phone or not.

    If I were in this position, what I'd do is reinstall the firmware from DFU mode, then activate in iTunes, then either restore contacts etc from backup or just by transferring them all across again. Bit of a pain but not as much of a pain as not being able to sync.
     
  3. Dm3k1 thread starter macrumors newbie

    Joined:
    Mar 12, 2009
    #3
    I'll give it a shot, i've tried restoring but maybe ill restore to an old version. Sorry I should have clarified, this is just a regular iPhone 2G, not jailbroken or anything.

    I've reinstalled itunes also to no avail, It seems like my computer, when i try to do the restore and sync on my PC is works fine. Gah, I think its just my Macbook :(, Support is pointless....
     
  4. sambo1 macrumors newbie

    Joined:
    Mar 6, 2009
    #4
    Im having the same problem. Were you able to solve it ?



     
  5. pmanija macrumors newbie

    Joined:
    Apr 19, 2006
    Location:
    Lithuania
    #5
    I had the same problem, after digging around, I've found, that when you click in "About iTunes" tab it showed "Activation-only Mode".

    Then I remembered that I've tried some Terminal commands regadring iTunes (Geniuos bar mode, activation mode and similar). Just disable all the modes using Terminal. You can get commands in - http://www.hackint0sh.org/f128/44716.htm

    Hope it help's. It did for me...
     
  6. jrobinson264 macrumors newbie

    Joined:
    May 20, 2010
    #6
    Re:


    THANK YOU!!!!!!!! THIS WORKED!!!!!!!
     
  7. adra21 macrumors newbie

    Joined:
    Nov 20, 2011
    #7
    Hi guys,

    I was having the same issue with that error message, and the tip to check the 'About iTunes' and see that it was activation only totally saved me, thank you! I changed that and then everything went fine. Below is the code to type into a command prompt to make the change:

    To turn on Activation-only Mode on Mac OS X:
    1. Make sure iTunes isn’t running and then open Terminal.
    2. In Terminal, enter a command:
    ▪ To turn activation-only mode on: defaults write com.apple.iTunes StoreActivationMode -integer 1
    ▪ To turn activation-only mode off: defaults delete com.apple.iTunes StoreActivationMode
    To turn on Activation-only Mode on Windows:
    1. Make sure iTunes isn’t running, and then open a Command Prompt window.
    2. Enter a command:
    ▪ To turn activation-only mode on: "C:\Program Files\iTunes\iTunes.exe" /setPrefInt StoreActivationMode 1
    ▪ To turn activation-only mode off: "C:\Program Files\iTunes\iTunes.exe" /setPrefInt StoreActivationMode 0
     
  8. tecchi, Apr 7, 2017
    Last edited: Apr 7, 2017

    tecchi macrumors newbie

    tecchi

    Joined:
    Apr 7, 2017
    #8
    This did not work! Anything else I can try?

    Update: It worked. However, I copy pasted the command from here and it worked.... Strange thing is that the command (
    defaults delete com.apple.iTunes StoreActivationMode ) is exactly what you have mentioned above! finally, that stupid error has gone away :3
     

Share This Page