Cannot text more than 1 picture

Discussion in 'iPhone' started by Shikaka, Jan 18, 2015.

  1. Shikaka macrumors regular

    Joined:
    Sep 12, 2014
    #1
    Ever since I got my 6+ I haven't been able to send more than one picture at a time via text message. Trying to send two or more pictures takes forever and usually won't go through.

    Any idea what I might be doing wrong?
     
  2. richwoodrocket macrumors 68020

    richwoodrocket

    Joined:
    Apr 7, 2014
    Location:
    Hamburg, NY
  3. Shikaka thread starter macrumors regular

    Joined:
    Sep 12, 2014
  4. mattopotamus macrumors G5

    mattopotamus

    Joined:
    Jun 12, 2012
    #4
    How are you trying to send a picture? From the photo app or from the messaging app?
     
  5. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #5
    Try it this way.

    Go into Photos, and in the top right corner click on Select.
    Click on all the pictures you wish to send.
    Then in bottom left corner, click on the icon (box with arrow up).
    Select Message.
    Input the name of the contact you want to send to.
    Click on Send.
    Profit.
     
  6. Shikaka thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #6
    I have tried sending from both the photo and message apps. In the message app, below the photos I am attempting to send, I see a blue bubble with no text inside.
     
  7. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
  8. 01silver4 macrumors 6502a

    01silver4

    Joined:
    Oct 4, 2014
    Location:
    Florida
    #8
    That's odd send more than one pictures all the time using iMessage. U try rebooting your phone? Or turning it on and off?
     
  9. iThingsGurl macrumors 6502a

    iThingsGurl

    Joined:
    Dec 3, 2014
    Location:
    Canada
    #9
  10. ET iPhone Home macrumors 68040

    ET iPhone Home

    Joined:
    Oct 5, 2011
    Location:
    Orange County, California USA
    #10
    You're lucky you can send 1 photo. I have a sim-free 6+ on ATT and I can't even send a photo via iMessage internationally and domestically at all. I have to send pics through an email account. I don't know how to fix this either.

    Do you have a data account? Is data even required? According to the plan I have with ATT, the TEXT PLAN includes unlimited texts, picture mail, and video mail (nothing about it having to have data for this to work).
     
  11. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #11
    iMessage doesn't use your texts, it sends everything over your data connection.

    If you have iMessage turned off then it would use your unlimited texting plan.
     
  12. ET iPhone Home macrumors 68040

    ET iPhone Home

    Joined:
    Oct 5, 2011
    Location:
    Orange County, California USA
    #12
    Your response here helped solved my issue - THANK YOU! So, I went into Settings > iMessage and noticed it was turned OFF. I turned it ON and am now able to send picture mail via iMessage domestically and internationally.

    But, what I don't understand is, as you say, if iMessage is off, it would utilize my texting plan. Initially iMessage was off and I couldn't even send any picture mail. Every message failed - "undelivered". Why?
     
  13. Shikaka thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #13
    Checked my settings and noticed "Send as SMS" is turned off. Why wouldn't this be "On" by default?
     
  14. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #14
    Do you have data turned off? That's the only thing that has ever given me trouble sending MMS. Either that or for some reason your phone hasn't downloaded the correct settings.

    Because iMessage is on by default.
     
  15. ET iPhone Home macrumors 68040

    ET iPhone Home

    Joined:
    Oct 5, 2011
    Location:
    Orange County, California USA
    #15
    I don't have a data plan for it. Initially, iMessage was OFF. Upon your troubleshooting (thank you again), I turned it ON and am now able to send picture texts.

    But when I turn iMessage OFF, picture texts are "all" UNDELIVERED. Only regular texts are deliverable.

    Both means whether iMessage is ON or OFF, have no data plan involved. I thought the texting plan was its own plan not affected by the need of data.
     
  16. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #16
    Do you have data turned off in the settings app? MMS messages even on your texting plan use data, it is just billed differently as far as the carrier is concerned so it wouldn't count as pay per use data or against a data plan. I often use prepaid without a data plan so I've run into that issue as I keep data turned off in the settings so I don't run through all my credit by apps using data in the background.
     
  17. ET iPhone Home macrumors 68040

    ET iPhone Home

    Joined:
    Oct 5, 2011
    Location:
    Orange County, California USA
    #17
    Yes, DATA is OFF in the SETTINGS app. I am on a pre-paid plan on ATT for $25.00 which includes 250 mins./Unlimited Text/Unlimited International Text. I really don't need Data. Do you think I should get data? I use my MBA for internet more than my iPhone.
     
  18. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #18
    You don't need to get a data plan, but it does have to be turned on in settings for MMS to work. You might want to call AT&T to confirm, but I believe that with that plan they block data so your phone can't use it since there is no data plan. But if Data is turned on in the settings app MMS will work.
     
  19. ET iPhone Home macrumors 68040

    ET iPhone Home

    Joined:
    Oct 5, 2011
    Location:
    Orange County, California USA
    #19
    Alright, thanks again. I did notice my texts bubbles are colored green, therefore, are unitizing my text plan. Tomorrow, I'll turn data ON to see if the text bubbles turn blue.
     
  20. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #20
    They will keep using your text plan even with data on so they should stay green as long as iMessage is off. What turning data on should do is allow MMS messages to go through using your text plan.
     

Share This Page