Cannot unlock file in Xcode 6.1. Remote file error

Discussion in 'iOS Programming' started by ashishn, Nov 27, 2014.

  1. ashishn macrumors newbie

    Joined:
    Nov 27, 2014
    #1
    I created new project but cannot add any UI element to the view. I get lock icon and if i try to unlock then get a message

    The file “Main.storyboard” could not be unlocked. The file is a remote resource. Try making a local copy.

    screenshot

    What could be the reason and how to resolve? I also checked from Finder that none of the files are locked. I tried creating another project but getting same error.

    I had created one tutorial project earlier and that also faces same issue.

    I am running Xcode 6.1
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    Is this still a problem?

    Are you creating the projects on your hard drive or are they on some kind of mounted server? What is the full path to your project folder? It needs to be inside your home directory. I have a folder ~/develop where I put all my project folders. If your project is inside a system folder you might get this kind of problem.

    If the files really are on your local hard drive then this is probably some kind of permissions error. Try running Disk Utility and choose 'Repair Disk Permissions' on your hard drive. If that doesn't help run in the Terminal 'ls -laR /path/to/project/folder' to inspect the disk permissions.
     

Share This Page