Cannot update apps in iTunes or on iPhone

Discussion in 'iOS Apps' started by higgalls, Aug 4, 2008.

  1. higgalls macrumors regular

    Joined:
    Mar 20, 2008
    #1
    Hi,

    I have been having problems with my apps, but the latest problem is that there are 2 programs that have updates available (1 of them is free, and the other is a program I paid for):

    Program 1:
    BreakClassic
    Price: Free
    Version on phone: 0.9
    Version to update to: 0.9.1

    Program 2:
    GuitarToolkit
    Price: $12.99 (aussie dollars)
    Version on phone: 1.1
    Version to update to: 1.1.1

    When it checks for updates and says those updates are available, it says they are both free updates, but when I say to download all updates, it comes back with the error message titled "MZCommerceSoftware.OwnsNoneSoftwareApplicationForUpdate_message", and it says, "You can not update this software since oyu have not owned the major version of this software".

    If I try and update the programs individually, the message comes up saying "You do not qualify for this price. This discounted price is only available to customers who own a previous version of this item. To purchase this item at full price, click OK"
    I don't want to click on OK to purchase it again, as I already paid for GuitarToolkit, and don't want to pay again when the update is free.

    When I try and do the updates on my phone, it comes up saying, "This discounted price is only available to customers who own a previous version of this item. To purchase this item at the full price, click OK"

    One interesting thing I just tried was with the free BreakClassic program. I ended up clicking on OK to purchase it, as it is free anyway, and when I did, it came up with the message, "Purchase of this item is not currently available. This item is being modified. Please try again later."

    Does anyone have this problem? Any solutions?

    Cheers,
    Chris
     
  2. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #2
    I get a few of those errors myself. As long as the programs aren't broken I don't mind waiting for updates.
     
  3. higgalls thread starter macrumors regular

    Joined:
    Mar 20, 2008
    #3
    I just found out that BreakClassic actually does now cost money. It is $1.19 (aussie dollars), but it should still be free for current owners as it is only a minor update.
     
  4. MacinJosh macrumors 6502a

    Joined:
    Jan 29, 2006
    Location:
    Finland
  5. MacinJosh macrumors 6502a

    Joined:
    Jan 29, 2006
    Location:
    Finland
    #5
    Surely we can't be the only ones with this problem? You don't happen to have authorization issues as well, do you?
     
  6. shedali macrumors newbie

    Joined:
    Mar 31, 2007
    Location:
    London, England
    #6
    same problem here

    The appstore red badge indicates that 5 programs require updating.

    One of them is omnifocus - wen I click install, I can see the installation progress on the application icon and then a warning message comes up saying

    "This discounted price is only available to customers who own a previous version of this item"; if I cancel I lose the update. If i press 'buy' it says 'This item is currently being modified. Please try again later".

    So I am unable to update my apps. . .
     
  7. higgalls thread starter macrumors regular

    Joined:
    Mar 20, 2008
    #7
    I have no idea what is going on here with the apps.
    I have been having problems where I cant even open my apps at the moment (they close within 1 second of opening), and I have been on the phone to Apple several times over the last few days (I have another phone call booked in today to do a reload), and so far nothing has fixed it.

    I am actually wondering whether iTunes 7.7.1 has caused the problems?
    Does anyone know how to uninstall the 7.7.1 update, so that we only have version 7.7(.0)?

    Cheers,
    Chris
     
  8. ineyjoe macrumors newbie

    Joined:
    Sep 17, 2008
    #8
    Updates

    From what I can tell, it seems that the only apps that won't give me the free update are the ones which I do not have the MOST RECENT previous version. i.e. When I try to update an app that is version 1.3 and I have version 1.1 (and there was a version 1.2). Hope this helps. I have decided that I need to update my apps more frequently, or they need to fix this problem.
     
  9. SFC Archer macrumors 68000

    SFC Archer

    Joined:
    Nov 9, 2007
    Location:
    Troy, MT
    #9
    Go to iTunes and click "Store", "Authorize Computer" and re-authorize your accounts. Then shut down iTunes and open again, check for updates and update.

    This should work for most users. When you updated to 8.0 some accounts got de-authorized and for the most part this is the fix. It will not add to your authorized 5 computers.

    Good Luck
     
  10. sdelucia2 macrumors newbie

    Joined:
    Sep 18, 2008
    #10
    Same error

    I get the same error, but my apps won't even sync to iTunes, i get the message "not authorized to play them on this computer". I tried unauthorizing and reauthorizing my itunes, but that didn't work. I downloaded my apps straight to the phone and they won't even start up now, so I can't just wait. Help please!
     
  11. ilfn143 macrumors 6502

    Joined:
    Aug 27, 2008
    Location:
    Enron by the Sea
    #11
    cannot update stanza, it said 1.4 in update when click on it said 1.3 already installed :(
     
  12. sdelucia2 macrumors newbie

    Joined:
    Sep 18, 2008
    #12
    A Solution

    You can delete and then reinstall your applications to get them working again. You should get a message that you don't have to pay to download it again when you reload it. Otherwise report the double charge to the itunes store. This solution worked for me.

    To delete an application, hold your finger on it until it starts to jiggle and then press the x that now appears in the corner. To reinstall, go back the app store and "buy" it again.

    Hope this helps.
     
  13. oftheheavens macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #13
    DO NOT DO THIS!!!!!!!!!!!!!!!!!!!!!!!!

    I did this for chopper and since that is one of the first apps i got in July they said they could not pull that bill up. i paid for chopper twice. try that re-authorizing thing mentioned above. that might work
     

Share This Page