Cannot upload to iCloud Drive

Discussion in 'iOS 9' started by mcaswell, Aug 19, 2015.

  1. mcaswell macrumors member

    Joined:
    Dec 22, 2013
    #1
    Cross-posting this to El Capitan and iOS9 forums, as the issue exists in both.

    Having a bizarre problem with iCloud Drive... downloads work, but I am unable to upload files, whether dragging onto the iCloud Drive folder in the Finder on El Capitan, or saving from an app like Pages or Numbers in El Capitan (PB4) or on the iPhone/iPad (iOS9 PB4). It looks like it's trying, but the "thermometer" indicator sporadically moves forward, then goes back, over and over. Tried signing out/in of iCloud, which did not help (the iCloud Drive folder was repopulated by my iCloud files, but again, I was unable to upload).

    However, this behavior only seems to occur when I'm on WiFi / Ethernet... if I disable WiFi on my phone the test file will upload through LTE. Thinking perhaps it was something with my ISP (Charter Cable) maybe blocking a port or something, I stopped at several places today that had public WiFi (confirmed that at least two of the ones I tried did not have not Charter IPs), and the same problem occurred.

    Back home, I found that if I connect through a VPN (which I don't normally use... just trialing it), the upload is successful. I also found that I could upload through the iCloud.com website (with or without VPN).

    Though I don't want to roll back my iPhone and iPad to iOS8, I did reboot my Mac Pro into a Yosemite backup, and iCloud uploads DO work.

    So, to summarize:

    Home network with El Capitan or iOS9 – iCloud upload fails
    Other WiFi networks with iOS9 – iCloud upload fails
    Home network with El Capitan iCloud.com – iCloud upload succeeds
    Home network with El Capitan through a VPN – iCloud upload succeeds
    LTE connection with iOS9 – iCloud upload succeeds
    Home network with Yosemite – iCloud upload succeeds

    Anyone else having this problem?
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    Try restarting your router.
     

Share This Page