Resolved cannot use Buffalo USB optical drive

Discussion in 'MacBook Air' started by keevill, Apr 12, 2012.

  1. keevill, Apr 12, 2012
    Last edited: Apr 13, 2012

    keevill macrumors member

    Joined:
    Nov 7, 2010
    #1
    I have an MBA 11in running Lion 10.7.3.
    It can detect my Buffalo USB optical drive in the 'about this mac' section but it cannot open it nor read it.
    When I plug it in the light on the front flashes away like it's going to open but nothing.
    Any ideas anyone ?
    -keevill-
     
  2. Skoopman macrumors 6502

    Joined:
    Sep 24, 2011
    #2
    What Buffalo drive is it exactly? I have an old external drive with USB 1.1 (yes, you heard right :D) and I had the same problem once. Somehow, after I plugged in the drive, it couldn't read it anymore and I had to reformat it. Can you plug it into a Windows machine to see if it works there?
     
  3. keevill thread starter macrumors member

    Joined:
    Nov 7, 2010
    #3
    It works in Windows, Linux but whilst being seen by Mac OS , the drive cannot read any dvds.
    Not sure what you mean by reformatting - can't do that to a drive can I ?
    It is not an old model ( about 12 months old ) and is model number DVSM-PC58U2V
    Thx,
    -keevill-
     
  4. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #4
    Reformatting would be for a hard drive and not an optical drive.

    Have you tried using a different USB port on your Mac or a different USB cable? ALthough this should be an issue since you see it in "About This Mac".

    Have you tried an Audio CD in the Buffalo drive on the Mac or just DVDs? And were the DVDs you tried data discs or movies?
     
  5. keevill thread starter macrumors member

    Joined:
    Nov 7, 2010
    #5
    I've tried audio/pic/movie dvds and it can't open any of them ...
    -keevill-
     
  6. keevill thread starter macrumors member

    Joined:
    Nov 7, 2010
    #6
    Solved

    I plugged the device into another port and it worked.
    Strangely, a USB port in a docking station connected to the MBA and not the two inbuilt ports.
    -keevill-
     

Share This Page