Cannot view 4k on Mac Pro 3,1

Discussion in 'Mac Pro' started by rokeros, Jan 25, 2014.

  1. rokeros macrumors newbie

    Joined:
    Jan 25, 2014
    #1
    I just recently bought a 4k 39" display to replace my dual 24's. I've been doing a lot of research and thought I was on the right path. I have a Mac Pro 3,1 early 2008 and replaced the old ATI card for an ASUS GTX 650 ti. It worked fine on 10.8.4 after installing Nvidia drivers, but there was no option available to display at 3840x2160. Therefore I decided to upgrade the OS to 10.9.1 to see if it helped. On 10.9.1 the GPU worked fine plus now it has the option to go 3840x2160. However, whenever I try to select that option, the screen crashes on a grey screen and I am forced to perform a hard reset.

    My display supports 3840x2160 @ 30Hz and I have verified this with my Retina MBP with no issues. But somehow my Mac Pro won't do it. I have also tried SwitchResX with no luck either.

    Am I missing something out here? Or drivers missing I need to install? Please help me as I am stuck with a giant 4k display with seriously low resolutions right now...
     

Share This Page