Cannot view/open files in networked folders...

Discussion in 'Mac OS X Server, Xserve, and Networking' started by ealpin, May 14, 2008.

  1. ealpin macrumors newbie

    May 14, 2008
    I have a bit of an issue here with my new iMac...I must warn you, I'm a Mac n00bie...:)

    I've got a few folders on my Windows machine that are shared, one containing photos another containing videos, and the third housing all of my .mp3 files. I'm able to access these folders from my iMac using the "Connect to server..." option from Finder, but can only view the actual files of my music folder. If I have files directly in that shared folder and not in a sub folder, Leopard will see them but will give me an error when I try to open them (they're just pictures so there isn't a file type problem). If I click on a sub folder, Leopard doesn't see any of the files in that folder. For my music folder, all files can be seen and accessed, even those in sub folders. Any ideas as to why Leopard can't see my sub folder files or allow me to open the files it can see?

    Just to make things more interesting, I'm sharing another picture folder from my XP laptop that is fully viewable and Leopard will open any file that I choose.

    I'm kinda lost as to why it's doing this and have been pulling my hair out for hours trying to figure out why. Any help/ideas will be greatly appreciated! In the meantime, I'm going to try running a Windows update and seeing if that may fix anything. Oh, and one other thing...How can I change the usernames/passwords that I have stored in my keychain? Thanks!
  2. MacDaddy08 macrumors regular


    Feb 13, 2008
    The only thing I can think of is that you may have read only permissions on the Windows shares. I am on my Mac right now and wont be back on a Windows computer until tomorrow morning. I will confirm then the steps to take. There is a way to change the sub folder settings to inherit the permissions of the parent folder. What i would do first is right click on one of the sub folders from the windows machine that you are having the problem with. Click on sharing and security and then permissions. Make sure that the "everyone" user has full access so that anyone connected on your network can view/change files in that share.

    If that is the case, I will check tomorrow when I get to work on how to change the sub folders to inherit permissions.

    As for your keychain passwords you have to open your applications folder and then open "utilities"
    In utilities there should be keychain access. Click on that and in there you can view your passwords and change them as you wish.

Share This Page