Cannot view Video in Quicktime audio plays fine

Discussion in 'Digital Video' started by Avi, Apr 9, 2009.

  1. Avi macrumors member

    Joined:
    Feb 28, 2009
    #1
    Hello

    I have a .mp4 file which is 1280x528 its a H264 movie file. It plays well in VLC but I can get only the audio to work in Quicktime but no video.

    Same thing in Front Row

    I have Perian installed. Is there any way I can get the video working in Quicktime so that I can play the video in my Front Row playlist.

    Thanks
     
  2. CaptainChunk macrumors 68020

    CaptainChunk

    Joined:
    Apr 16, 2008
    Location:
    Phoenix, AZ
    #2
    The video could be using the DiVX or XviD codec, for which you need plugins in order to play in Quicktime-based applications.

    The DiVX codec installs components that allow you play both.
     
  3. Avi thread starter macrumors member

    Joined:
    Feb 28, 2009
    #3
    Thanks for the reply Captain Chuck.

    But the Divx install did not work. I still have Audio but no Video

    The movie file is .mp4
    1280x528
    H.264 .AAC
    6 Channel sound

    Any help is appreciated! Thanks! :)
     
  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    Have you got the latest QT installed?

    It's strange, as Apple highly promotes the .h264 codec.
     
  5. Avi thread starter macrumors member

    Joined:
    Feb 28, 2009
    #5
    Yes sir got the latest Quicktime with Perian installed. :)
     
  6. OneMike macrumors 601

    OneMike

    Joined:
    Oct 19, 2005
  7. jjjcoop23 macrumors newbie

    Joined:
    Mar 31, 2009
    #7
    try downloading (free) MPEG Streamclip and just convert the file to a quicktime file.

    easy and free.
     
  8. Avi thread starter macrumors member

    Joined:
    Feb 28, 2009
    #8
    I will try that and let you know how it works out Thanks
     

Share This Page