Cannot watch high quality videos on Youtube?

Discussion in 'macOS' started by SuperSnake2012, Oct 27, 2008.

  1. SuperSnake2012 macrumors 6502a

    Joined:
    Oct 11, 2005
    Location:
    NY
    #1
    I'm not sure how to fix this problem guys... I tried this in three different browsers (Safari 3, Firefox 3, Camino). When watching a video on Youtube, it always defaults to standard quality. When I click on high quality, it gives me an error message saying the video is no longer available. I sent my friend a link who opened it in his Safari and it shows the high quality one. Does anyone have any idea on how to fix this?

    Example from the front page: http://www.youtube.com/watch?v=Dla2lxOZx38
     
  2. jimleszczynski macrumors regular

    jimleszczynski

    Joined:
    Jan 19, 2008
    Location:
    Mount Pleasant, MI
    #2
    I have the exact same computer with the same specs. I don't seem to have this problem. Have you made sure that any and all current updates have been installed? Are you running 10.4 or 10.5?
     
  3. illegallydead macrumors 6502a

    illegallydead

    Joined:
    Oct 22, 2007
    Location:
    Colorado!!!
    #3
    This has nothing to do with how good of a computer you have. All it has to do with is what your internet connection is like the moment you want to watch the video. YouTube analyzes it, and decides what quality you "can handle".

    I remember reading somewhere that you can force it to load the high quality by adding something to the end of the url, but I do not remember exactly how this was done. You might do a google search on that, I believe I read it in a Popular Science magazine a few months back...

    Good luck!
     
  4. RemarkabLee macrumors 6502a

    Joined:
    Nov 14, 2007
    #4
    You can force YouTube to play the HQ version by adding the following at the end of the URL in your browser:
    Code:
    &fmt=18
    Note however, this only works depending on the original video format the author used when the video was uploaded. So for example, if the author uploaded in h.264 format, the HQ version will be vastly better than the standard FLV format.

    Here's a good example:

    HQ: http://uk.youtube.com/watch?v=50DHHMBIJf8&fmt=18

    Standard: http://uk.youtube.com/watch?v=50DHHMBIJf8
     
  5. Tom B. macrumors 65816

    Tom B.

    Joined:
    Mar 22, 2006
    Location:
    London
    #5
    Or you could try going into your profile settings and selecting 'always play in highest available quality' or something along those lines.
     
  6. RemarkabLee macrumors 6502a

    Joined:
    Nov 14, 2007
    #6
    Doesn't always work though :(
     
  7. BrettFarve04 macrumors regular

    Joined:
    Sep 14, 2007
    Location:
    Milwaukee, WI
    #7
    Do you have to always manually put in &fmt=18 at the end of the URL or is there a way to make that default??
     
  8. SuperSnake2012 thread starter macrumors 6502a

    Joined:
    Oct 11, 2005
    Location:
    NY
    #8
    It's not my connection speed, I have a 15Mbps/2Mbps connection. I used to be able to watch HQ videos, but for some reason it stopped working. Adding the fmt thing to the end of URLs doesn't work, I still get the error. :confused:
     
  9. stainlessliquid macrumors 68000

    Joined:
    Sep 22, 2006
    #9
    I have a video I uploaded myself that gives me that error in standard quality but not high quality. But other people keep commenting on it and I can see it on the PS3 so obviously its still there. Theres probably a logical explanation, try clearing your cookies.
     
  10. SuperSnake2012 thread starter macrumors 6502a

    Joined:
    Oct 11, 2005
    Location:
    NY
    #10
  11. HardRave macrumors newbie

    Joined:
    Feb 25, 2009

Share This Page