Cannot write to NTSF drive, already installed macfuse and ntfs-3g

Discussion in 'macOS' started by jadasneez, Jan 7, 2011.

  1. jadasneez macrumors newbie

    Joined:
    Jan 1, 2011
    #1
    Hi i've purchased a 2TB external drive, i downloaded and installed macfuse and ntfs-3g AND tuxera ntfs and i formatted the drive to ntfs. Everything was working perfectly (reading and writing) until i unplugged the drive form my computer. So when i plugged the drive back in, it could only read and no longer can write information.

    What is going on? i didnt even turn off my computer, the only thing i did was backup my computer with time machine (onto a seperate drive NOT the NTFS one) and plug the new drive back in. Ive reinstalled all 3 programs and restarted my comupter but nothing seems to be working.

    any help would be greatly appreciated
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    First, I really hope you're joking when you say you installed NTFS-3G and Tuxera NTFS. They're not meant to be run at the same time. Uninstall one of those, pronto! I would recommend uninstalling the Tuxera NTFS, I've heard several problem reports from using it and none from using the free NTFS-3G. Just doing that could solve your issues.

    Just to check as well, you did eject the drive properly before you unplugged it (either dragged the icon to the Trash, right-clicked on the icon and chose eject, or used the Finder sidebar, among other methods)? If you didn't, you could very likely have corrupted the drive. NTFS drives on the Mac are particularly sensitive to that kind of behavior. I'd recommend, if the first suggestion didn't help, that you plug it into a Windows PC and see if it offers to fix the NTFS table (or whatever the terminology is). I've seen that work a few times on NTFS drives that had gotten corrupted.

    jW
     

Share This Page