Canon 5D m-ii not recognized

Discussion in 'Digital Photography' started by MBX, Nov 2, 2009.

  1. MBX macrumors 65816

    Joined:
    Sep 14, 2006
    #1
    Hi

    No idea what's going on but suddenly my Canon 5D isn't recognized anymore. I don't know what's going on but i called Canon and they couldn't help me. Might be that the camera CPU itself is messed up and not interacting with my computer/ software properly?

    Everything was fine until about yesterday when i connected the cable and the EOS utility didn't start up as it usually does. I tried a few times more and then sometimes it would do nothing or only launch the utility and freeze.

    I uninstalled and installed again, updated version, didn't help. And now it doesn't do anything at all.

    The camera is not even recognized or listed in Bridge or Lightroom.

    At the same time it's strange that the camera reacts to me pluggin the cable into it. The menu on the screen appears or sometimes the red light comes on but nothing happens.

    Any idea?

    I thought i'd ask here for some suggestion before i return/ exchange the camera as i'm baffled at why this now is happening when before it was all fine.

    (i'm on SnowLeopard/ MBP17'' unibody. not that it really matters as previously it worked flawlessly with my 7D/ 5D)
     
  2. stagi macrumors 65816

    stagi

    Joined:
    Feb 18, 2006
    #2
    Is everything else with the camera working fine and can you still shoot and transfer from a card reader?
     
  3. joelypolly macrumors 6502

    Joined:
    Sep 14, 2003
    Location:
    Melbourne & Shanghai
    #3
    Restart?

    Silly to ask but have you tried restarting your Mac?
     
  4. MBX thread starter macrumors 65816

    Joined:
    Sep 14, 2006
    #4

    The camera seems all fine and working but it doesn't show up on my computer and neither in the EOS utility, therefore can't get/ transfer anything from the card.

    And yes i restarted many times.

    I'm not sure if this is the reason but i think it started happening when i did a "dust sensor cleaning" for the first time. But why should this make the connection work anymore?

    I kinda reached dead end now and will exchange camera for another 5d and see if the problem still occurs.
     
  5. someoldguy macrumors 65816

    Joined:
    Aug 2, 2009
    Location:
    usa
    #5
    Just as a long shot ... have you tried downloading with different CF cards in the camera? I've also had EOS Utility crash during relatively big downloads ,
    i.e. 100 or more RAW+large jpegs , so now use Bridge as my downloading program.
     
  6. MBX thread starter macrumors 65816

    Joined:
    Sep 14, 2006
    #6
    I said it's not the downloading that was the problem. The problem is i can't even download from cam because the 5D isn't recognized!

    Neither with the EOS utility nor in Bridge or LightRoom!
     
  7. Phrasikleia macrumors 601

    Phrasikleia

    Joined:
    Feb 24, 2008
    Location:
    Over there------->
    #7
    It's most likely to be a problem on the computer end of things. Try plugging the camera into different USB ports. Sometimes that helps.
     
  8. MBX thread starter macrumors 65816

    Joined:
    Sep 14, 2006
    #8
    what could it be then and how can i fix it?

    the camera does react to the plugging but nothing happens on the computer side of things.

    i tested on all usb ports and no difference.

    what more can i do?
     
  9. rost12 macrumors member

    Joined:
    Feb 6, 2008
    #9
    Try using a card reader? At least you could get your images downloaded.
     
  10. peskaa macrumors 68020

    peskaa

    Joined:
    Mar 13, 2008
    Location:
    London, UK
  11. akdj macrumors 65816

    akdj

    Joined:
    Mar 10, 2008
    Location:
    Alaska
    #11
    You are using a Mac, correct?

    If so, plug in the 5d2, wait 30 seconds or so...then launch iPhoto. If there is camera interaction through the USB, iPhoto shoud show it's [Import] Screen. If not, try uninstalling your DPP and Image Browser software (from Canon) and any of it's preferences....

    Then reinstall the latest DPP/IB software from Canon's site.

    Have you recently upgraded to Snow Leopard (or any other OS)?

    I just bought the 7d a couple weeks ago...I also own a 5d2. I updated my DPP software on my Macs (MBP and MP) and I can't use it anymore...Just crashes the program when I plug my cameras into the Mac. Again, Snow Leopard and Intel based MBP and Mac Pro.

    My workflow is now straight off my card reader...for some reason, I haven't found the Canon software all that reliable on my Macs...I'm using ACR or Lightroom/Aperture for RAW files (still waiting on 7d update though:))

    Good Luck

    J
     
  12. wheezy macrumors 65816

    wheezy

    Joined:
    Apr 7, 2005
    Location:
    Alpine, UT
    #12
    Get yourself a card reader - not sure why it would stop working. Locate the preference files in your /Library folder and trash them all, that might help. Some bit in some file just got corrupted, nothing bad.

    Your best, and fastest bet, is to just get a card reader. I have a Lexar FW800 and it pulls the files off my cards just lovely like. Especially cause I'm using a 300x Card (45MB/s). I had a cheap USB2 reader and it worked about half the time. It seemed I always needed to do some plug/plug dance just to get the darn thing to read it, it was really annoying.
     
  13. fiercetiger224 macrumors 6502a

    Joined:
    Jan 27, 2004
    #13
    Try it on another computer. Mac or PC, and see if it's being detected. If not, then maybe there's something wrong with the USB port, or something in the camera itself.
     
  14. MBX thread starter macrumors 65816

    Joined:
    Sep 14, 2006
    #14
    Can you tell me which files in /Library that would be and how i can replace them?
     
  15. pigbat macrumors regular

    Joined:
    Jan 18, 2005
    #15
    This actually isn't all that silly. Many people skip this step. I'd suggest powering down completely to make sure the USB bus gets reset. Also, make sure you don't have fusion or parallels active.
     
  16. mahood macrumors member

    Joined:
    Aug 6, 2009
    Location:
    UK
    #16
    Try a new USB cable? Any cable that fits should work, USB->Mini USB - it's not a special Canon-only one.

    Also try creating a brand new account on the mac - if it's a software clash, this should help flush it out. If it works under a new user, at least you know the hardware's good...

    If you have access to another computer, try it there - any PC or Mac will mount the camera as a USB device, so you can drag the pictures off.

    If not, have a go at this sequence:

    1. Shut down the Mac (totally). Power off at the wall if you like.
    2. Shut down the camera. Pull the batteries. Re-charge them if you like, but wait at least 5 minutes before putting them back in.
    3. Power on the Mac, let it boot all the way and don't start any apps.
    4. Power on the camera.
    5. Plug them together.
    6. Cross your fingers that it worked.

    I second the advice to use a card reader - at least to get the shots off the card before you do all this. It's seriously unlikely to cause them to get deleted, but why risk it?

    You could also try to format the card in the camera, I've seen this work before (when it really shouldn't make a difference). Only do this AFTER getting the pics off somehow.

    Failing that, it's all got to go back to Canon (hopefully) under warranty.

    Good luck,

    Mark
     
  17. MBX thread starter macrumors 65816

    Joined:
    Sep 14, 2006
    #17
    OK i know what's going on now: The camera (or some of it's parts/ CPU) is defective.

    I plugged my friends 5D and it recognized it without a problem.

    And also it's 5D is much more noise-free and doesn't get vertical banding so much (and both same firmware) at lower light.

    On my way exchanging it in the next days.
     
  18. hlinton macrumors newbie

    Joined:
    Jan 18, 2010
    #18
    Not Necessarily the CPU

    I have 2 5D's [MK I] and just discovered that neither of my Mac computers [both running Snow Leopard] will recognize either camera right away. I didn't have any problem getting recognition when connecting one of them to a PC running Vista. And yes, I tried all of the above suggestions without much luck.

    BTW - The only reason I connect a camera directly to the computer is to run Camera Window so as to sync the time between both bodies with the computer clock. Its the only way to keep them accurately synced allowing the images to appear in Aperture as they were shot.
     
  19. fishhawkbill macrumors newbie

    Joined:
    Feb 14, 2008
    Location:
    Florida, thankfully.
    #19
    Canon 5D II will not mount on OSX 10.7

    Old thread but I was consulting it so maybe this will help someone.

    My old Canon EOS T1i mounted with no problem, directly into Aperture 2 &3. But my new 5D II is invisible. I use a Belkin USB hub to make a couple of ports available without having to access the back of the computer.

    However, if I plug the USB directly into the computer (an iMac 27" i7) it mounts immediately.

    So the problem in my case at least was something about the Belkin switch.
     
  20. mralan13 macrumors newbie

    Joined:
    Jan 19, 2015
    #20
    I have a similar problem. It had been working fine and now it isn't recognized. I have found that I can open and download and export my images by opening in iPhoto. Why iPhoto recognizes it and nothing else does is beyond me. It is getting the job done but I prefer gong directly from the camera or better yet from a card reader. Unfortunately all of my card readers are down so I don't have that option.
     
  21. Rnee Erne Nree macrumors newbie

    Rnee Erne Nree

    Joined:
    Nov 18, 2015
    #21
    I'm going to bump this old thread because I have the exact same problem, and I want to see if someone has found a solution. But before, a little bit of information of my problem:

    My camera, a 7D, is not being mounted on my mac. When I plug the USB cable, the camera makes a noise, but nothing happens on the computer. I open the EOS utility, which is what I need to use, and everything is greyed out. I made a full re-install of OsX 10.11.1 El Capitan, since I was having other problems as well. It was a fresh start and every other problem got fixed, except the one with the camera.

    I have a card reader, but I need to use the computer to instal the Technicolor Cinestyle Picture Style through the EOS utility. To my knowledge, there simply is no other way to do it. I have tried different USB cables. My warranty has expired. I have not tried speaking with a canon representative, since I'm in México and not sure how to reach costumer service here.

    Any idea how to solve this issue? It would be greatly appreciated.
     
  22. USAntigoon, Nov 20, 2015
    Last edited: Nov 20, 2015

    USAntigoon macrumors regular

    USAntigoon

    Joined:
    Feb 13, 2008
    Location:
    Rochester Hills, MI
    #23
  23. Rnee Erne Nree macrumors newbie

    Rnee Erne Nree

    Joined:
    Nov 18, 2015
    #24
    Thanks USAntigoon, but the problem is not with the software itself, I think. The software opens. The problem is that my camera and my computer don't communicate with each other, so even though the software opens, I have every option greyed out, as in I can't select anything.

    As I explained in my original post, the option of a card reader is of no use for me, since I'm not trying to download the images, but to install a Picture Style through the EOS Utility.

    Thanks for the links, but still no solution to the issue. Anybody else?
     
  24. USAntigoon, Nov 23, 2015
    Last edited: Nov 23, 2015

    USAntigoon macrumors regular

    USAntigoon

    Joined:
    Feb 13, 2008
    Location:
    Rochester Hills, MI
    #25
    May be a simple question...Do you use the USB ports on the backside of the iMac ...

    Edit: I also like to add this url with some more info..
    http://photofocus.com/2015/10/02/canon-eos-utility-vs-macs-new-os-el-capitan/
     

Share This Page