Canon EOS 7D not importing properly into Mac iPhoto

Discussion in 'Digital Photography' started by ofc, Feb 17, 2012.

  1. ofc macrumors newbie

    Joined:
    Feb 17, 2012
    #1
    Hi All,

    I am having a very odd problem with my iPhoto as of late, as I'm not sure if this problem lies with my camera or with iPhoto, but my guess is iPhoto.

    There are a number of shots on my Canon that I can see with the view mode, and when I attach the camera to the computer, they are visible when iPhoto asks what photos to import, but once they are imported, they either don't actually import into iPhoto, or if they do, they import as black squares - nothing more.

    Any advice or suggestions as to what is happening would be so appreciated.

    THANK YOU!
    :)
     
  2. mofunk macrumors 68000

    mofunk

    Joined:
    Aug 26, 2009
    Location:
    Americas
    #2
    It could be your SD card. or CF card. If you erase/format your cards with the computer instead of the camera, you will have problems transferring photos. I've seen it happen with a lot of cameras. It doesn't matter if its a DSLR or a P&S.

    When you don't format your card with the camera's software you will have problems.
     
  3. ofc thread starter macrumors newbie

    Joined:
    Feb 17, 2012
    #3
    Thanks for your reply. That definitely makes sense, although I haven't done any changes to the card through the computer - only the camera...
     
  4. davidinva macrumors 6502a

    Joined:
    Mar 29, 2009
    Location:
    Shenandoah Valley of Virginia, USA
    #4
    Use a card reader. It simplifies life. Format the card in camera as others suggest.
     

Share This Page