Canon HG10 and Final Cut Pro 6

Discussion in 'Digital Video' started by snowman102185, Mar 16, 2009.

  1. snowman102185 macrumors newbie

    Joined:
    Mar 4, 2009
    #1
    I am having a problem downloading my clips from my Canon HG10 into FCP. I have downloaded many clips from this camera before without any problems and don't believe I have changed any settings since then but FCP will not even recognize the device as even being connected. I have tried many different settings and researched quite a bit and nothing has seemed to help.

    I have copied all of data off of the camera to a folder on my desktop and don't see a way to transfer into FCP that way either. The only thing that I have found online that might be the culprit is doing a HDD initialization, but like I said I have had successfully transferred clips before so don't think this is the problem.

    Anyone have any ideas?
     
  2. snowman102185 thread starter macrumors newbie

    Joined:
    Mar 4, 2009
    #2
    It must have been my cable. Came home with the camera, let it sit on the counter for 3 or 4 days and then plugged it in tonight with a different USB and worked flawlessly.
     

Share This Page