Canon HV20 Humming Noise

Discussion in 'Digital Video' started by nomad2010, Oct 17, 2007.

  1. nomad2010 macrumors newbie

    Joined:
    Sep 27, 2007
    #1
    Just got my canon and recorded for just a second and there is this terrible humming noise. it is so distracting. any ideas what to do? should i return it and go for the sony instead?
     
  2. LeKiD macrumors regular

    LeKiD

    Joined:
    Aug 31, 2007
    #2
    Talk to the seller... exchange it... try again. If it does it again... exchange it or buy an external microphone.
     
  3. nomad2010 thread starter macrumors newbie

    Joined:
    Sep 27, 2007
    #3
    i guess its the only con people could find with it. they all have it. i just don't know what to do since they all have it. will canons dm 50 external mic work ok?
     
  4. LeKiD macrumors regular

    LeKiD

    Joined:
    Aug 31, 2007
    #4
    You have to check the mic entries. The best would be to find out ways people dealt with it on other forums... Or the people who sold it to you could probably answer some questions about audio... I hope!
     
  5. Artful Dodger macrumors 68020

    Artful Dodger

    Joined:
    May 28, 2004
    Location:
    In a false sense of reality...My Mind!
    #5
    http://www.amazon.com/RODE-VideoMic...7?ie=UTF8&s=electronics&qid=1192674436&sr=1-1

    Try this mic, well look into this one as it has some great reviews for the price if you need to help rid the motor sound from your cam. I'll be getting one very soon myself. Good luck :)
     

Share This Page