Canon i-Sensys LBP7018C Problem

Discussion in 'Mac Accessories' started by D9B, Mar 14, 2014.

  1. D9B macrumors newbie

    Joined:
    Feb 19, 2014
    #1
    Hi,

    I have the following problem.
    I bought a new Canon i-Sensys LBP7018C printer which is connected via USB.
    Also I've installed drivers and everything looks ok - even green light next to a printer's icon in the "Printers and Scanners" window.
    When I try to print anything I've got two results:
    - error message informed me that printer isn't connected
    - or nothing ….

    I've tried on Macbook Pro 13, iMac 27 - OS X 10.9.2
    and Mac Mini - OS X 10.8.5

    I've changed USB cable few times. Tried via Time Capsule - nothing
    Based on Canon, this printer is supported on Maverick and ML

    Tried also two different version of Driver: 3.65 and 3.40

    When connected to windows 8.1 (Bootcamp) works perfect :(

    Any ideas ?
    Maybe any alternative driver?

    Thanks for any help
     
  2. D9B thread starter macrumors newbie

    Joined:
    Feb 19, 2014
    #2
    Update to my previous post:

    I've created VM with OS X 10.9.2 (clean system) and printer has been connected to VM and…. it works.
    Tried to back and connect like before and doesn't work (on phisical Macs).

    Strange….

    Any ideas how to remove all current drivers? Maybe something is blocking my printer?
    Why three independent computers are affected by this problem, why VM with Mac OS works properly ?

    Sorry for so many questions
     

Share This Page