Canon MF4270 Printer Problem

Discussion in 'Mac Basics and Help' started by macpccouple, Jun 2, 2008.

  1. macpccouple macrumors newbie

    Joined:
    Jun 2, 2008
    #1
    My husband bought a Canon ImageClass MF4270 Laser Multifunction Printer/Fax/Copier. We also have a new router which is a Linksys WRT150N. I have a MacBook using OSX 10.4.11. In the past with our old router and our old printer, i had no problem with wireless printing. With our new setup, i cannot get my computer to recognize the printer. i have tried every suggestion in the manual. i have tried installing the drivers from the CD and downloading them from the Canon website. I also tried to connect my laptop with a USB to the printer and it still would not recognize it. My husband is able to print from his PC. I am able to connect to the internet through the router. Please help.
     
  2. macpccouple thread starter macrumors newbie

    Joined:
    Jun 2, 2008
  3. papajerry macrumors newbie

    Joined:
    Jun 1, 2008
    #3
    Canon MF4270.................

    Delete the printer from your system and re-install getting the new drivers then try again. Connect your printer to the computer with both turned off, turn on the computer and let it boot up then the printer.:apple:
     
  4. atlanticza macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
    #4
    You could try this

    Macs have the former Unix utility, CUPS (Common Unix Printing Service) installed and printers can be managed in this way. For access to this, type the numbers 127.0.0.1:631 into your browser.
     
  5. mrwizard macrumors newbie

    Joined:
    Jan 3, 2007
    #5
    Similar problem

    We (me and my wife) bought a Canon MF4270 today. Since she has a PC and I have a Mac we elected to set the printer up as a network printer (I gave it a fixed IP address). Therefore the USB connection is not being used at all (the printer is not connected directly to any computer - access is only through the network).

    The printer had a setup CD that came with it, and it worked perfectly for the two PCs that she uses in her office.

    The problem came when I tried to get my Mac to talk to it. Since the PCs can print to it with no problem we KNOW that it is connected properly and responding to network access/traffic. In fact, when I try to access the printer via my browser, the printer responds perfectly.

    The REAL problem is getting my Mac's printer system to recognize the driver software. I started by installing the UFRII version 170 software, and the installer claims that the software was properly installed. But when I try to setup the printer in the printer control panel, I set up an IP printer and supply the IP address the printer is set for, but when I try to select the driver, I choose Canon, and the list of canon drivers shows up, and although other Canon models show up in the list, the MF4270 is not in the list.

    I then went back to the Canon web site and saw they had a Fax driver for the printer, so I downloaded it (it's version 210) and installed it. When I go to setup the printer again, the FAX driver shows up, just as it should, but the PRINT drivers are still not in the list. Although I don't expect to use it to fax docs from my computer i finished the FAX setup anyway, and gave it a try, and it shows up in my available printers and responds exactly as it should. But that's fine for Faxing, but does NOT let you print.


    I then did a search on the internet, and saw that there was an older version of the PRINT driver, version 161, so I downloaded it, uninstalled version 170, and installed version 161. Same thing - the PRINT driver doesn't show up in the list during setup (but the FAX drivers are still there).

    So I uninstalled version 161, and uninstalled the fax drivers (version 210), shut the computer down, restarted it, tried another printer setup, and now the Fax drivers are missing (as they should be since I uninstalled them) and the PRINT drivers are not showing up either (as they should be) .... and then I reinstalled version 170 PRINT drivers. (of course the install process made me restart the computer) ... and when I tried to perform a setup, the PRINT drivers still don't show up in the list of Canon printers.

    I even found an alternate source for the version 170 drivers (that had a different file name - o84benx.dmg) and uninstalled the previous drivers and tried installing from this file - it said the install was successful - but they still don't show up in the setup list.

    I'm running an intel iMac with OSX 10.4.11 on it (the computer won't run 10.5 - long story, so I won't go into that now - so switching to 10.5 is not an option)

    The short summary is:
    - the computer CAN talk to the printer via a browser (so we know that the wiring/address/access IS working)
    - the FAX drivers DO show up and I can complete a setup using them and they work properly
    - the PRINT drivers are not being listed as available printer models in the setup printer list, no matter whether I use version 161 or version 170

    By the way, during all the installing/uninstalling I was doing I was looking in ~/library/printers/canon and the UFRII folder was being added or removed properly (depending on whether the drivers were supposed to be installed or uninstalled at the moment) - so even when the drivers were not showing up during the setup process, they WERE installed in the printers folder where they should be.

    At this point, I'm stumped. I can't think of anything else to try.

    Also, I tried going to CUPS and there is no driver there for the MF4270 (in fact - no drivers for ANY of the MF series)
     
  6. mrwizard macrumors newbie

    Joined:
    Jan 3, 2007
    #6
    I got it working!!!!

    I found a post on a forum at Apple.com posted by Evan. He said ...

    I also had a nightmare installing this printer, but i finally got it resolved. I originally used DHCP Auto to assign ip, subnet, etc. and no matter what I did, it would not recognize the printer and install the appropriate driver using the "Other Printer" section and selecting UFR II. I could enter the IP address of the machine, but it would always come back as Generic for the driver.

    I resolved it, after much frustration, by doing the following:
    1) Turned DHCP Auto off
    2) Manually entered IP 192.168.1.XXX
    3) Manually entered Subnet 255.255.255.000
    4) Manually entered Gateway 192.168.1.1
    5) Turned SNMP ON
    6 Most importantly, I re-entered the SNMP Community name back to default - which is "public" all lower case
    7) Restarted the copier

    UFR II Printer Driver V1.70 for MacOSX
    http://www.usa.canon.com/consumer/c...oadDetailTabAct&fcategoryid=335&modelid=15753

    Immediately after doing that, I uninstalled and reinstalled the Canon Driver program (UFR II) and selected Other Printers, entered the manual IP address I assigned, and like magic (after about 5 minutes of scanning the printer), it worked. It selected the correct driver and it now works flawlessly. One other note, I plugged the network cable directly into my network switch, not my Airport Extreme port. Theoretically, it should also work by plugging the cable into the router, but I didn't seem to have any luck doing it that way. Anyways, hope it works for you.

    MF4270 Network Printer Mac OS X (10.5.3)


    Since I had already setup my printer for a fixed IP address I had steps 1 thru 7 already done.

    For me the breakthrough was selecting "Other Printer" (on MY screen it said "More Printers") and entering the address the printer was set to ... then the UFRII series showed up and it setup with no problem. Interestingly, the MF series STILL do not show up using my old setup method.

    But the "More Printers" method worked like a champ!

    I don't know if this will help the 'not printing multiple pages' problem (because _I_ wasn't having that problem) but it may be worth a try. Even when the page has graphics on it it prints in less than 10 seconds (it slowed down to about 30 seconds to spit out the first page when I sent 4 pages with lots of graphics).

    By the way, for what it's worth, I have printer's ethernet cable plugged into a 5-port switch, that is plugged into an 8-port switch, that is plugged into one of the ports of my Linksys WRT-160 wireless router ... and my computer is connected via wireless. So my print jobs are going from my computer via wireless, to the router, to the 8-port switch, to the 5-port switch, to the printer. So it looks like the wireless and several bounces thru switches are not being a problem.

    So macpccouple, give that a try. I hope it works for you as well as it did for me.
     
  7. mrwizard macrumors newbie

    Joined:
    Jan 3, 2007
    #7
    By the way ....

    The "scanning" functions don't work thru an ethernet connection, but that's only because the Canon software doesn't support it.

    If Canon will get their act together .... the communication problem is solved ... now CANON needs to get the scanning software built for Mac OSX to allow scanning to be done via ethernet connection (IP address).
     
  8. TimmyR macrumors newbie

    Joined:
    Sep 6, 2008
    #8
    OK...great thread. Please help. I have the printer drive installed and am connected via USB. Is there a trick to getting the fax and scanner working? I am connected to an iMAC running OS 10.5.4

    Thanks from a Mac new-guy....just switched out all my Windows based syatems for Macs.
     
  9. mrwizard macrumors newbie

    Joined:
    Jan 3, 2007
    #9
    I gave up

    After fighting with this thing for almost a week (and discovering that you had to find a 'workaround' for almost everything) I gave up and returned it to Staples, where they let me exchange it for an HP M2727 All-In-One.

    The HP just worked! The way it was supposed to. It was easy to setup, and it came with software for both PC and Mac on separate CDs.

    Yes the HP was $100 more, but it was worth it.

    Not only can I use it as a network printer (with drivers that worked the very first time), but, unlike the Canon, I can also Fax and Scan through the network (not just by USB like the Canon).

    Another really nice feature that the HP had, but is lacking on the Canon ... since I run an office out of my home I'm not ALWAYS in the office, so if I happen to be in the kitchen getting a snack and the phone rings and it's an incoming fax, (from the kitchen phone) I can press 1,2,3 and the HP picks up the line and the fax machine takes over. I can then hang up the kitchen phone while the machine continues to receive the fax. On the Canon, they had something similar, but 1) it only works from a phone you have plugged into the back of the fax machine (which rules out answering it in the kitchen) and 2) sometimes it works, the majority of the time it doesn't.

    So I'm sorry to admit defeat ... but I'm REALLY glad that I got the HP instead. The HP is a better machine all around. It just works!
     
  10. jejarrett macrumors newbie

    Joined:
    Sep 2, 2008
    #10
    So were you able to scan with this thing to the Mac?? either USB or network?? I would love to take the piece back, but too far out from date of purchase!!

    thanks
     
  11. TimmyR macrumors newbie

    Joined:
    Sep 6, 2008
    #11
    Never tried to get the scanner to work once I found the small grey writing on the Canon site that excluded scanning from the Mac compatability.

    I bought a Brother 7840W. It has drivers for the Mac. Once those are installed, you can update them from the Brother site. I've had a couple minor hiccups but it seems to work well now.
     
  12. srjenkins macrumors newbie

    Joined:
    Oct 26, 2012
    #12
    Just wanted to add this for anyone else that is having this problem and who might be also have a Windows machine on their network. I had the same problem described in this forum, but the solutions offered didn't totally fix it on the Windows Vista machine. Here's one other thing to try.

    Make sure SMNP is turned off at the printer.

    1. Press the Additional Functions button.
    2. Press "-" or "+" until you get to System Settings.
    3. Then, select Network Settings.
    4. Then, select SNMP Settings.
    5. Then make sure Use SNMP is off.

    Then, make sure it is also off in the Windows printer configuration.
    1. Go to Control Panel > Printers & Faxes.
    2. Right-click on relevant Printer and select Properties.
    3. Select Ports.
    4. Select IP port you are using and click Configure Port.
    5. Uncheck SNMP Status Enabled.

    This in conjuction with the above also solved the printing problem on my Vista Windows machine.
     

Share This Page