Canon mp568 stops, gives error message

Discussion in 'Mac Accessories' started by Suketa, Feb 1, 2011.

  1. Suketa macrumors newbie

    Joined:
    Feb 1, 2011
    #1
    :) I so hope that someone can help me out, I was trying for several days now to fix the problem, but to no avail.

    I attached my canon pixma mp568 to the MacBook (Snow Leopard 10.6.6) and can print and copy, but not scan. I installed and deinstalled the contents of the CD as well as various canon printer, scanner and MP Navigator Ex updates in several orders and combinations, but nothing works. I even reinstalled Snow Leopard! After doing that at one point the scanner worked briefly for 2 scans, but then went back to the error message (An error has occurred. Turn off the device and then back on. Scanner driver will be closed.Message 2.520.20). :confused:

    - It is possible that it stopped working again after I had installed the large os x update, but I am not sure about that -

    What else could I try? For example, which is the correct order to install the drivers, which ones do I need and can I leave aside MP Ex Navigator, since Image Capture seems to be good? And should the scanner/printer be attached and on while installing downloads or should it be off? If I connect it, os x detects the printer on its own.

    If anyone can solve this problem, PLEASE let me know...
     
  2. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #2
    See my post here (http://forums.macrumors.com/showthread.php?t=1080630), as I hate the Canon software and have had nothing but problems.

    I cannot find the MP568 on the Canon support site, but try this based on what I saw under MP560:

    * download the CUPS printer driver and the scanner driver
    * install the printer driver first then install the scanner driver (think it might ask for a restart after)
    * run Mac Software Update, see if there's a Canon update
    * go into System Preferences to add the printer and scanner ... when you hit the + the scanner should show up right away, and give it a minute or so for the printer to show up

    This is what works for me.
     
  3. Suketa thread starter macrumors newbie

    Joined:
    Feb 1, 2011
    #3
    @jenzjen

    Thank you jenzjen, I saw your earlier post and tried just this, but it was not working, probably because the mp568 is a multi-device printer with scan and copy function. I should have mentioned that. In any case, therefore it does not appear as printer and scanner separately, it is seen as one device and I should be able to switch from printer to scanner inside that very box which opens by clicking on the printer in system preferences, or automatically. (It worked twice, so it's possible).

    Here is what the system profiler says, maybe this could help to solve the problem. Scanning support is there, but no scanning applications are visible:
    Status: Idle
    Print Server: Local
    Driver Version: 10.36.2.0
    Default: Yes
    URI: usb://Canon/MP560%20series?serial=245EA8
    PPD: Canon MP560 series
    PPD File Version: 10.36.2.0
    PostScript Version: (3010.000) 705
    CUPS Version: 1.4.6 (cups-218.28)
    Fax support: No
    Scanning support: Yes
    Scanning app: -
    Scanning app (bundleID path): -
    Scanner UUID: 00000000-0000-0000-0000-323435454138

    I understand why you don't like Canon - it has a hard time with Mac. Before with the PC it was working so much better than the HP and I was so happy, for it's an excellent machine. So hopefully I can find ways to cope with both Mac and Canon....

    Here's one link to the updates: http://support-in.canon-asia.com/P/...=download&filter=0&tagname=g_os&g_os=Mac OS X


    I tried: CUPS Printer driver, Scanner driver 15.4.1a, sometimes ICA driver, MP Ex Navigator 3.04, MP Ex Navigator Opener

    Maybe with your experience you can see where the communication problem between Canon and Mac is located. Thanks again for your help!
     
  4. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #4
    Sorry, that's the extent of what I know. I have the MX870, which is a MF fax, copy, printer & scanner so yours should work just fine. On mine, I do have 2 devices listed under my system preferences, 1 printer and 1 scanner, even though they are the same physical device.
     
  5. Suketa thread starter macrumors newbie

    Joined:
    Feb 1, 2011
    #5
    @jenzjen

    Now that's beyond my understanding. But thank you anyway for sharing your knowledge.
     

Share This Page