Canon MP600 scanner not working - help!!

Discussion in 'Mac Accessories' started by exige, Mar 30, 2008.

  1. exige macrumors newbie

    Joined:
    Mar 30, 2008
    #1
    I have a Canon MP600 scanner/copier/printer. It's connected to my MacBook which I purchased in Sept 2007. I have 10.5.2 on my computer. Computer's HD failed after 4 months, then flex cable (BUS cable?) had to be replaced about a week ago. Scanner worked fine before 10.5.2 and the hard driver failing.

    Scanner scans the document, but a screen pops up on the computer that says "Unable to save file. The system cannot find the path specified."

    I've updated and installed all the drivers from Canon's website. I cannot figure out what is causing the problem, or how to rectify it?

    Please offer any help you can. Thanks!
     
  2. Cave Man macrumors 604

    Cave Man

    #2
    Sounds to me like your scanner software is expecting certain file path (directories) in which to save files. You might want to check the preferences for that software to make sure what it's expecting to find is really there.
     
  3. anthony11 macrumors 6502

    Joined:
    May 18, 2007
    Location:
    Seattle, WA
    #3
    Cave Man: the problem is that Canon's software automagically appends a dated subdirectory to the path to save, eg. ~/Pictures/MP Navigator/Mail_20081121. Somewhere in the preferences is a button to turn this off, but it doesn't seem to apply globally. If one manually creates today's subdirectory, it works, but this is annoying and inconvenient.

    I suspected that the space in the default directory name was causing problems, so I renamed mine without the space and selected the new name in the directory chooser everywhere I could find in Preferences and Button Settings, and now it works for me. I'll speculate that Canon's software is failing to escape the space properly somewhere.
     
  4. mennoh1 macrumors newbie

    Joined:
    Jun 16, 2009
    #4
    Canon MP600 scanner needs newest driver for Mac OSX 10.5

    I had the same problem: suddenly the scanner took ages to calibrate/warm up. Turns out it had to do with the upgrade to Leopard or one of the updates (I'm on 10.5.7).

    I downloaded the newest OSX scanner driver from Canon:
    http://www.usa.canon.com/consumer/controller?act=ModelInfoAct&fcategoryid=2610&modelid=13800

    Now it scans without delay. Could have saved myself a lot of waiting a lot earlier!

    Saving scans:
    I always scan from the MP Navigator instead of from the scanner itself, so I can pre-edit the scans and save as .jpg to the folder I want and/or as a .pdf. Works for me....
     
  5. aquanautII macrumors newbie

    Joined:
    Mar 7, 2009
    #5
    iMac 27" w/osX 10.6.3 (Snow Leopard)

    I did this when I first bought the computer. But recently I did the weekly software update and in that was a "Canon Printer Software Update 2.3" that I did install. Then a few days ago I tried to use the scanner using the MP Navigator and now I get a message "scanner failure". I believe it to be that Canon update.

    I went thru the System Preferences using the Print & Fax icon but it only scans just segments of a copy into very large sections.

    I went to the System Profiler and under Hardware>Printer it shows the MP600 but under "scanner support" it says "NO".

    So now, I sneak in the back door using the PhotoStudio and I go thru "Acquire", the little picture of a scanner in the tool bar. But, I still can not get it to save in .pdf files. So when I finally run out of ink (two full packs) I'm dumping Canon back to my old computer. At least the scanner works there.

    This really sux!!!! Every time I upgrade to a newer osX I have to change printers.
     
  6. yappa macrumors newbie

    Joined:
    Aug 10, 2010
    #6
    This worked for me.

    • Computer is Apple MacMini with 10.6.4 Snow Leopard
    • I _did_ allow Software Update to install the "updated" Canon software to 2.3
    • I _did_ download and install the Scanner _only_ software here.
    http://gdlp01.c-wss.com/gds/2/0900002202/04/mp600osxsd12131ej7.dmg

    Now scanning using the buttons on the front panel is working fine.

    NOTE : I suspect you might need to remove Canon's MP Navigator software to get this to work. I have never installed it on this Mac.
     
  7. mym8John macrumors newbie

    Joined:
    Sep 18, 2010
    Location:
    Surrey, England
    #7
    I had same problem after restoring from back up

    My hard drive failed recently and I had to restore the system from by back up. I then had this same problem. I seem to have fixed it now.

    I got some tips from this thread.
    http://www.fixya.com/support/t1334257-unable_save_file_system_cannot_find

    No single suggestion there worked but they pointed me to what to try.

    I ran MP Navigator and then clicked on Preferences. Then a changed the 'Save In' value to something different. (It was 'user/Pictures/MP Navigator' and I changed it to 'user/Pictures').

    Didn't work.

    I then clicked 'One Click' and changed the 'Save In' value to in the same way as described above (saving directly in the Pictures directory).

    My scans were then saved automatically again. The odd thing is they were still saved in the 'user/Pictures/MP Navigator' directory even though I changed both save paths.

    I then changed them both back to show the full path for neatness and it still worked.

    I don't know whether it was the second change I tried which solved the problem or a combination of the two. Just thankful it seems OK now. To be honest I may have changed the one click setting first then the preferences one.
     
  8. Coach Dale macrumors newbie

    Joined:
    Dec 27, 2010
    Location:
    Dallas TX
    #8
    MX Navigator

    My problem is slightly different.

    I got a new 27" iMac (Yay!) The MX850 is connected via Ethernet, not USB. It's actually in a different room.
    I "Migrated" all my software from my old 24" iMac, most worked but the Canon scanning did not. Looked at a lot of these threads, tried a lot of stuff, reinstalled the Canon drivers, and I got to this point:
    1. If I scan from within MX Navigator, everything works including saving as a PDF file.
    2. If I scan from the MX850 panel as a "document" (i.e. a JPG), it works fine, saves in MX Navigator as normal.
    3. If I scan from the MX850 panel as a "PDF document" (i.e. a PDF), I then get the dialog box "Unable to save file. The system cannot find the path specified."

    This appears to have something to do with PDF versus JPG.

    I tried a lot of things, and got the new computer in a mess, and I wanted to reinitialize anyway, so I did an "archive and install" following these instructions: http://intlect.com/how-to-archive-and-install-os-x-snow-leopard/

    I am slowly getting everything back to normal. First thing I tested/noticed was that the Canon print drivers where already installed and they worked fine. Also the Apple version of scanning worked fine: use the "Image Capture" application and I could scan just fine from the computer. The front panel buttons don't work, the scan button doesn't detect my Mac. I would like the front panel buttons to work - did I mention the MX850 is in a different room?

    So I reinstalled these items from the Canon web site:
    http://www.usa.canon.com/cusa/snow_...rinters/inkjet/pixma_mx850#DriversAndSoftware
    1. MX Navigator (mpnexosx111ea8-2.dmg)
    2. IJ Network Tool (ntosxm270ea8-2.dmg)
    3. MP Drivers (mx850sosxns10ea7-3.dmg)

    Note I did not install ALL the software from this site, as I am only interested in getting the front-panel scanning to work...

    Also, I am confident that I did NOT need to install the IJ Network Tool as the MP Drivers include it, but I didn't know that at the time.

    Rebooted and configured the scanner - this was a little confusing as right after the reboot the IJ Network tool wants to configure the PRINTER and the dialog looks quite a bit like the one to configure the SCANNER. Since I don't need to use the Canon software to configure the printer (the Mac software is working just fine) I cancelled it, then went to the right-hand menu bar and selected the "Open Settings..." from the Canon IJ menu. And once again, I am back to the point where everything works EXCEPT scanning to PDF from the front panel of the MX850. Naturally, this is the function that I want to work the most...

    I hope this lengthy post helps someone else, and if anyone has any hints about what I should try next, I would greatly appreciate it!

    *Dale*
     
  9. djdj500 macrumors newbie

    Joined:
    Mar 5, 2011
    #9
    Resolution to MP600 No Scan

    Hit up the Canon website and navigate to the software and drivers area for your printer, select your OS and download:

    1. CUPS printer driver

    AND

    2. Scanner driver (they're not bundled, but separate downloads)

    AND

    3. Latest MP Navigator (3.0.4)


    Close all programs, turn on printer.

    DELETE Canon MP600.ds file in Library/Image Capture/TWAIN data sources

    DELETE current MP Navigator in Applications/Canon Utilites

    Mount .dmg's and install in the download order above

    Enjoy your scanner.
     
  10. anthony11 macrumors 6502

    Joined:
    May 18, 2007
    Location:
    Seattle, WA
    #10
    Indeed, for that's about all the CUPS driver is usable for. I've tried printing photos through the CUPS driver, and the results were dire.
    I've given up on the 64-bit / Bonjour issue and have resigned myself to plugging my MP960 into my MBP when I need to print/scan. I've never tried to scan from the AIO's console - MPN is less than thrilling as an interface, but I need to use it so infrequently that I live with it. If I want to print something from another box, I just mail a PDF. Awkward, but also something I rarely need.
     
  11. katenandy macrumors newbie

    Joined:
    Jan 11, 2012
    #11
    MP Navigator on Mac (lion)

    Is there anyone who can help me please?

    We have a new mac computer.
    I scan an image and open it on my mp navigator in recently saved images. Then I click on the image to select and then go to edit where it should transfer to an editing page (on my old pc) but on my mac it only gives the option of "open pdf file". Even though it is scanning as jpeg. When you do click on "open pdf file" it comes up with an error.

    Has anyone else come across this problem ?

    Many thanks
     

Share This Page