Canon Powershot A590IS / Snow Leopard compatibility issues?

Discussion in 'Mac Basics and Help' started by kegsbytheriver, Sep 19, 2009.

  1. kegsbytheriver macrumors newbie

    Joined:
    Mar 11, 2009
    #1
    I've noticed that since my upgrade to SL my PowerShot A590IS isn't working properly. When I try to transfer pictures from the camera to my unibody Macbook, I receive the following message: "Failed to initialize program." I can see my newer photos in the Canon window briefly, and then the error message pops up and closes the window. Has anyone else experienced this? I MRgoogled, and google-googled, and couldn't find anything.
     
  2. davidinva macrumors 6502a

    Joined:
    Mar 29, 2009
    Location:
    Shenandoah Valley of Virginia, USA
    #2
    Canon Powershot A590IS problem

    I have the same camera, but always download via card reader (I use one that came with my SanDisk cards). If you don't have one, borrow one, and see if the same problem exists. Great little camera, by the way.
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    Can you try importing from the camera with iPhoto/Image Capture? If it works with those the Canon import software probably was not updated to work under Snow Leopard...
     
  4. pixlchik macrumors newbie

    Joined:
    Oct 7, 2008
    #4
    Having same problem!

    I tried updating the software drivers for this and thought it was going to work . . . got further than the first time (I used to just get the failed to initialize program message without seeing any of my images, and after installing what I believed was an upgrade, I saw the images start to download in the image browser, but then the msg popped up and the program quit again!).

    So, opened image browser rather than letting my camera start the process by turning it on when plugged in, and tried File > Connect to Camera (same results this way), then went to Internet menu and clicked Canon Digital Camera Website where it lists Firmware update information, but the A590 IS model is not in the list!
    What to do now??? Any help is appreciated!

    -Oh, and I'm running Macbook Pro, OS 10.6.1 (snow leopard)
     
  5. mtgentry81 macrumors newbie

    Joined:
    Jul 14, 2009
    #5
    I've been having the same issue with my digital rebel xt. Just got off the phone with apple and they say if you have an older version of iphoto (mine is v6) then there may be compatibility issues with Snow Leopard. His suggestion was to upgrade iLife.
     
  6. appseedpilgrim macrumors newbie

    Joined:
    Mar 1, 2010
    #6
    canon A590 IS and mac snow leopard 10.6 compatibility

    I have the same problem and it doesn't look like Canon or Apple updated the driver to work with 10.6 (instead of 10.5). Did anyone ever find a solution to this problem? [My macbook pro doesn't seem to even recognize that the camera is plugged in no matter where I look.] Any suggestions much appreciated.
     
  7. jpdemers macrumors newbie

    Joined:
    Mar 9, 2009
    Location:
    New York, NY
    #7
    Same with PowerShot SD750

    Canon and Apple don't play well together. :mad: I have a VMWare virtual PC, and the camera works fine on the PC side. If you don't have that, a card reader is the way to go. It's cheap enough to be a real solution, but be sure to get one that handles the newer SD formats.
     
  8. jackerin macrumors 6502a

    Joined:
    Jun 29, 2008
    Location:
    Finland
    #8
    Did you people even try the Image Capture route?
     
  9. jpdemers macrumors newbie

    Joined:
    Mar 9, 2009
    Location:
    New York, NY
    #9
    Solution!

    There is a Snow Leopard update to Canon's camera software:
    http://www.usa.canon.com/consumer/controller?act=DownloadIndexAct

    One possible glitch: you have to have the original software (from the CD that came with the camera) installed. Pain in the arse if you got the camera second-hand and don't have the CD. (Typical Canon: brilliant about hardware, but stupid about software.)
     
  10. Clutch Cargo macrumors newbie

    Joined:
    Apr 1, 2010
    #10
    Canon A590 Software update from Canon Website for Snow Lepoard

    My A590 would show the initial welcome window when connecting with Snow Lepoard, but after a few moments, the "failed to initialize program" error message would show. After a recommended visit to the Canon website, downloaded the latest update, all is cured. Thanks for the tip!
     
  11. Esteroid macrumors newbie

    Joined:
    Feb 6, 2011
    #11
    Update in February 2011: The Canon website listed with Snow Leopard updates does not appear to have CAMERA updates any more. :mad:

    I tried iPhoto and it seems to work fine to import. A bit awkward but workable. If anyone finds another place where Canon has posted software updates which work with Snow Leopard please post the info.
     
  12. DonandTasha macrumors newbie

    Joined:
    Apr 7, 2011
    #12
    Solution

    I was having the same problem (getting my Canon [Powershot G10] to transfer pictures to the computer after an update to Snow Leopard). I called Canon (1-800-OKCANON) and they were very helpful and emailed me a link to download an upgrade.

    Here's the link.... http://www.usa.canon.com/cusa/suppo...t_pro_series/powershot_g10#DriversAndSoftware (If you have a different camera, you need to select it before you proceed)

    Under "Choose Operating System:" select Mac OS X

    He had me download the 8th option.... ibx-upd-6-5-3-18-u01-8l.dmg.gz
    ImageBrowser 6.5.3 Updater (Mac OS 10.4-10.6)
    07/06/2010 66.08MB

    I restarted my computer after the download and it works perfectly! (It looks a little different now but works perfectly!!) Good Luck
     
  13. deadkennedy macrumors 6502

    Joined:
    May 22, 2010
    #13
    Just bumped into this problem today and solved it by using Windows. Thanks, it only costs around $100 to install Win7.
     
  14. mabrandt macrumors newbie

    Joined:
    Mar 22, 2012
    #14
    New software for Snow Leopard available from Canon

    I also have a Canon Powershot (A650IS is my model) camera and had the "Failed to initialize program" after switching to Snow Leopard.

    Installing ImageBrowser 6.7.2 Updater (6.5.3, if it once was available for my camera, no longer was/is listed) didn't resolve the issue for me.

    But, if you go to http://www.usa.canon.com/cusa/support/consumer and Select

    1) Product Type
    2) Product Family
    3) Model
    4) Drivers & Software
    5) Mac OS X v10.6

    you may also see new software that fixes the problem.

    For my camera, there were new versions of CameraWindow DC, PhotoStitch Updater, and ImageBrowser Updater (in addition to the ImageBrowser 6.7.2 Updater, I had already installed), as well as something new (to me anyway) called ImageBrowser EX. All had a Post Date of 3/20/12. Disclaimer: It is necessary that all available version(s) of the software be installed sequentially, oldest to newest.

    To do the installation of CameraWindow DC and ImageBrowser EX, you need your camera connected to the computer (based on your camera, the installer figures out what software it needs to download and install).

    With all 4 installed, the problem disappeared (I could again transfer images from my camera to my iMac, running 10.6.8).

    If I ever need to use it, hopefully the new PhotoStitch fixes the http://forums.macrumors.com/showthread.php?t=780185 issues.
     

Share This Page