canon powershot G9 software issue

Discussion in 'Digital Photography' started by anp12, Nov 12, 2007.

  1. anp12 macrumors newbie

    Joined:
    Aug 21, 2007
    #1
    I'm having an issue with the ImageBrowser software that came with my canon powershot G9. They assure me it is a problem with my mac, not the software, so I'm here looking for some help/answers.

    Here is the issue. There is a particular function of this software to process images taken in RAW format. When this is selected from the menu, a separate application called RawImageTask should open, but it doesn't. It tries to, and then aborts, and an error message appears. Now, the bizarre thing is that logged on as any other user on the computer, and this does not happen. Everything works beautifully. So, that is why they tell me is is something on my mac interfering with that user. any ideas?

    I have an iMac osx 10.4.10, not intel.
    thanks

    -adam

    also, let me know if this is the correct forum to post this. I wasn't sure if it should go somewhere else
     
  2. jerryrock macrumors 6502

    jerryrock

    Joined:
    Sep 11, 2007
    Location:
    Amsterdam, NY
    #2
    Looks like you have a problem with your permissions. Go to disk utility and do a permissions repair and see if that clears up the problem.
     
  3. anp12 thread starter macrumors newbie

    Joined:
    Aug 21, 2007
    #3
    I tried what you suggested. I went to disk utility, and chose repair disk permissions. There were some permissions that needed repairing. However, when I tried to use RAW image Task from ImageBrowser, nothing was changed.
    The error message window had the option the report the problem to apple, and I copied the message. Here is the first part, the rest was more details that I didn't understand. maybe you, or someone will know what I can do based on this info.

    thanks.

    Date/Time: 2007-11-13 20:30:46.400 -0600
    OS Version: 10.4.10 (Build 8R218)
    Report Version: 4

    Command: RAW Image Task
    Path: /Applications/Canon Utilities/ImageBrowser/DVCUtility/RAW Image Task.app/Contents/MacOS/RAW Image Task
    Parent: WindowServer [63]

    Version: 3.0.0.21 (3.0.0.21)

    PID: 808
    Thread: 0

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000001

    Thread 0 Crashed:
    0 com.canon.framework.IHLClasses 0x0012959c IHLUtility::isIBSendFile(FSRef*, unsigned long*) + 104
    1 com.canon.RAWImageTask 0x000066b4 -[RITAppController setReceivedFilesWithAppleEvent:] + 212 (crt.c:300)
    2 com.canon.RAWImageTask 0x00002c18 AppleEventHandler(AEDesc const*, AEDesc*, long) + 80 (crt.c:300)
    3 com.apple.AE 0x914fe960 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, unsigned char*) + 208
    4 com.apple.AE 0x914fe7fc dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 44
    5 com.apple.AE 0x914fe654 aeProcessAppleEvent + 284
    6 com.apple.HIToolbox 0x9329e2e0 AEProcessAppleEvent + 60
    7 com.apple.AppKit 0x937c6cbc _DPSNextEvent + 856
    8 com.apple.AppKit 0x937c67a8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 116
    9 com.apple.AppKit 0x937c2cec -[NSApplication run] + 472
    10 com.apple.AppKit 0x938b387c NSApplicationMain + 452
    11 com.canon.RAWImageTask 0x000027b4 _start + 392 (crt.c:267)
    12 com.canon.RAWImageTask 0x00002628 start + 48

    Thread 0 crashed with PPC Thread State 64:
     
  4. anp12 thread starter macrumors newbie

    Joined:
    Aug 21, 2007
    #4
    one more thing

    I searched my computer for this:
    com.canon.framework

    but could find no such thing, even when I searched as one of the users that had no problem accessing the RAWimage task. But I did find this:
    com.canon.RAWImageTask
     

Share This Page