Canon Printer on Sierra

Discussion in 'macOS Sierra (10.12)' started by eddjedi, Sep 20, 2016.

  1. eddjedi macrumors 6502

    Joined:
    Sep 7, 2011
    #1
    My Canon printer (LBP6020) has stopped working since installing Sierra GM. I tried downloading the latest drivers from Canon, but in their wisdom they seem to have locked the installer to only run on "known" versions of OS X, so it refuses to run on Sierra. Have tried rooting through the PKG for the driver file but can't find it. Also tried the generic gutenprint driver, but no luck.

    Any advice on how I can trick the driver installer to run on Sierra? I don't fancy waiting for Canon to release an update.
     
  2. neilah1 macrumors newbie

    neilah1

    Joined:
    Jan 20, 2007
    Location:
    San Francisco
    #2
    I couldn't get my Canon imageCLASS mf4880dw multifunction laser to work *at all* with the Canon installers with my macOS Sierra betas.... until last week, when out of the blue, Canon silently updated its installers and it installed and all was well like it was under El Capitan.

    I know you don't want to wait, but it seems Canon is working on it.
     
  3. gatorknight904 macrumors 6502

    gatorknight904

    Joined:
    Jul 24, 2011
    Location:
    Dallas/Ft. Worth
    #3
    I was just about to install Sierra and something told me to check these forums about my Canon printer. I am using a Canon Pixma Pro-100 Photo printer and Canon has not released the drivers for Sierra yet. There is nothing listed on the Cannon Support page for the printer.

    Now that would have been frustrating. I will wait to install until the Canon drivers are released.
     
  4. eddjedi thread starter macrumors 6502

    Joined:
    Sep 7, 2011

Share This Page