Canon Wireless Printer & Snow Leopard

Discussion in 'macOS' started by Ellen, Aug 28, 2009.

  1. Ellen macrumors regular

    Nov 3, 2007
    After installing Snow Leopard, my Canon MX700 printer works with a USB connection - but not wireless. The network tab for the setup utility is grayed out. Is anyone else having the same problem?
  2. opticalserenity macrumors 6502a

    Apr 14, 2007
    Yup, same for my MP620...hope they get it going soon.
  3. tdaniels033 macrumors newbie

    Aug 30, 2009
    I have an MX700 and am experiencing the same problem. I am on the phone with Mac tech support and not having much luck. They tried to tell me I need to call Cannon to get the IP settings and try it that way. I told him I have tried it that way with no luck and the printer provides my the IP and LAN information. The tech is going to get the network guru on the line, but I am not holding out much hope.
  4. beerelf macrumors newbie

    Nov 21, 2007
    Same here, but with a Canon MX860. I installed the driver from apple from here:

    And I was able to get to the Network utility, but the only thing that shows up when I go to add a printer is a canon scanner, not a printer.

    To get to the network utility, I had connect to the printer via USB and reboot my MBP. The button was then available to click.
  5. jmpage2 macrumors 68030


    Sep 14, 2007
  6. jmxp69 macrumors 6502

    Dec 10, 2008
    My Canon MP620 prints fine over wireless FWIW.
  7. Ellen thread starter macrumors regular

    Nov 3, 2007
    Thanks to another post, I checked and a new driver file for the MX700 is available. I installed it, and can print wirelessly again.

Share This Page