Canon wireless scanning problems?

Discussion in 'OS X Mavericks (10.9)' started by Achilles75, Nov 9, 2013.

  1. Achilles75 macrumors member

    Joined:
    Feb 25, 2011
    #1
    Since my upgrade to Mavericks, I have lost functionality from my Canon printer's scan button (on the printer control panel - I can still scan using the Canon software on my computer). The printer is a MG5320, computer is an early 2011 MBP. I seem to recall having a similar problem with a previous OS X update sometime in the past, but no idea what the solution was. Anyone else run into this issue?
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
  3. Achilles75 thread starter macrumors member

    Joined:
    Feb 25, 2011
    #3
    Updated all my drivers this morning. Didn't seem to work.
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Then delete the scanner and then add it back again using the new driver or deinstall the drivers, reboot and the add the driver again and then re-add your scanner. See if that helps.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    You need to reinstall Canon's MP Navigator EX software package. That installer will install the OS X background process that makes the scanner button work.

    You can find the download here under the "software" section.
     
  6. Achilles75 thread starter macrumors member

    Joined:
    Feb 25, 2011
    #6
    Thanks for the help. Removing and then reinstalling the drivers and the MP Navigator software fixed it.
     

Share This Page