CanoScan LiDE 90 won't load from disc into iMac

Discussion in 'Mac Basics and Help' started by deGenova, Mar 9, 2014.

  1. deGenova, Mar 9, 2014
    Last edited: Mar 9, 2014

    deGenova macrumors newbie

    Joined:
    Oct 4, 2012
    #1
    I need some scanner help here from an expert please - when I try to load the scanner from the disc using my new SuperDrive into an iMac 10.9 it stops at 60 % either as a partial standalone or the full version.

    I found a driver page (screen cap below) at Canon that say's no online drivers available - I must use the drivers that come with the disc. But of course - therein lies the rub.

    I cannot access the driver by itself from the disc either........

    BTW.....I dnlded + opened "VueScan" (it looks like it would work fine) for my CanoScan LiDE 90 (U 1,0) but you must buy it first - no trial. I can buy a new scanner for the price.
    -----------------------------------------------------------------------

    [​IMG]
     
  2. Robert Davies macrumors 6502

    Robert Davies

    Joined:
    Jul 28, 2011
    Location:
    People's Republic of Wrexham
    #2
    Go to > System Preferences > Printers and Scanners

    On the pane that opens there is a panel on the left with a + and -.

    Click on the + (make sure your scanner is plugged in to your computer and switched on)

    You should see you scanner in the next page that opens - click 'add'

    You should now be done. No downloading from Canon necessary at all.
     
  3. deGenova, Mar 10, 2014
    Last edited: Mar 10, 2014

    deGenova thread starter macrumors newbie

    Joined:
    Oct 4, 2012
    #3
    Tried that too - no luck.
    Also loaded the Mountain Lion driver (10.8) but I can't see any evidence of it.
    [​IMG]

    It loaded but I cannot find it in my APPLICATIONS FOLDER

    [​IMG]
     
  4. Janichsan macrumors 65816

    Janichsan

    Joined:
    Oct 23, 2006
    #4
    If you really only downloaded the driver, there is nothing to be found in your Application folder. It's a driver. It's buried somewhere in your system's guts. Try adding your scanner again like Robert suggested.
     
  5. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    Your installer CD, which came with your LiDE 90, would not likely be any use to you with 10.9 . You should either hope that Canon directly supports it (and not really likely with an older scanner), or that there is another solution. One is certainly VueScan - and you would need to justify the cost of that…

    Or, there's some other answers here: https://discussions.apple.com/thread/5485421?start=0&tstart=0
     
  6. deGenova thread starter macrumors newbie

    Joined:
    Oct 4, 2012
    #6
    Not quite true - I downloaded another driver from the same program and its listed where its supposed to be and is clickable and it works properly - i.e., its not buried in the guts somewhere. I have never had that kind of experience.

    The one part that did load for me (and is listed in the APPLICATIONS FOLDER) is called MP Navigator EX 1.0 and gives a limited functionality compared to what I want, which is called "ArcSoft PhotoStudio" ($70.00as a stand alone purchase) - its a much more functional part of the overall program, but I cannot load it in from the disc in the same way as I did with MP Navigator.

    I wonder why Navigator works in 10.9 but ArcSoft does not???

    As for buying VueScan - I might as well buy the driver.

    ----------

    As I mentioned in the post above "I wonder why Navigator works in 10.9 but ArcSoft does not???" etc.

    BTW - I did happen to read the post and followed the thread (yesterday) in the link you sent.
     
  7. deGenova, Mar 11, 2014
    Last edited: Mar 11, 2014

    deGenova thread starter macrumors newbie

    Joined:
    Oct 4, 2012
    #7
    SOLVED - Called Canon - there will be no 10.9 driver for my scanner.

    The 'parts' I was talking about above were not drivers, but merely pieces of bundled software that came w/Lide90 one of which (MP Navigator EX 1.0) is still compatible w/iMac while "ArcSoft PhotoStudio" is not.

    Thanks for all the replies.....now I know how it works when purchasing a product that offers 'bundled' software.
     
  8. bedouin macrumors member

    Joined:
    Mar 3, 2011
    #8
    If you'd like to use this scanner under El Capitan with VueScan be aware that you will need to install the last available version of Canon's drivers AND the 32-bit version of VueScan. The 64-bit version of VueScan will not identify the scanner—probably because the drivers themselves are 32-bit.

    I stumbled upon this thread while trying to find a solution to this problem. I thought I'd add this so that it might be of assistance to someone in the future.
     

Share This Page