Canoscan LIDE20 software wont install

Discussion in 'macOS' started by Nadiestar, Jan 17, 2008.

  1. Nadiestar macrumors newbie

    Joined:
    Jan 17, 2008
    #1
    Hi there

    i own as iBook G4 and cannot get the software for the canoscan Lide20 to install. I have been on Canon's website and downloaded a recent copy of the drivers but i can't seem to find the application to open the file and run the setup.

    I have been to numerous places and ultimately i get the same result. I can download the software but i can't find the application on my MAC to run it.

    I am running Mac OSX 10.4.11 and i purchased my MAC in November 05. The scanner i am trying to use was the scanner i had for my old PC which i purchased in Sep 03. I don't have the discs anymore but i'm sure that just downloading the software will fix the problem if only i could get the thing to open and run setup!
    I had the same problem with my old printer and i ended up buying a new one but i would prefer not to do that as i am short of funds and i am sure i am being blonde.

    When i download from canon it tries to open with Quicktime but won't as it says is not a movie file. And when i download from other sites it tries to open it with WORD!!! I can't find anything else on my MAC that would do the job.:confused:

    Any help please!!! It's really important that i scan in some documents ASAP and send them away.

    Thank you in advance. :)
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    I don't remember what format Canon's downloads are compressed as (particularly stuff for a really old scanner), but it's possible you need to download Stuffit Expander (the free version). If the file ends in .sit, this is definitely the case.

    Even if it's a format that your Mac can decompress without help (say, .zip or .gz) Stuffit can also handle that, so it's a way to work around if the files aren't being handled properly.

    Alternately, if you go to the file that gets downloaded, do a "get info" on it, and go to the "Open with" section, one of the options there should be BOMArchiveHelper--that's the MacOS's built-in decompressor. Select that, and click "Change All" below, and double clicking should then work. Should.

    Related note: I have the previous scanner to that model (the 670--I think it's essentially the same hardware), and I have to say that Canon's OSX support for their old scanners sucks. (It's a shame, because the support for their printers is great, and I otherwise like the company.) I did get it working--I needed to first install the Scangear v7.something, then the driver package (Canoscan 4.something, I think), and at that point it basically functioned--but I could only scan directly with its built-in app (via the buttons). The plugins were so old they won't run in Photoshop, GraphicConverter, or the like.

    I got so fed up I eventually ended up going with the freeware TWAIN Sane package:

    http://www.ellert.se/twain-sane/

    ...which lacks a descreen option, and doesn't use the buttons on the scanner, but otherwise handles scanning quite well, and plays nicely with scanning directly into newer apps.

    Alternately, there's ViewScan, a shareware package which does basically ANYTHING with any scanner. However, at $40, it's not a cheap option for an old, bottom-of-the-line scanner when you could buy a brand new one for not much more.
     
  3. stokeyite macrumors newbie

    Joined:
    Mar 25, 2008
    #3
    Canon Lide 20 Drivers

    I had a problem with my LIDE scanner after upgrading to 10.4.11. My powerbook G4 no longer recognized the scanner. An update of the drivers for the LIDE 20 is available on the canon USA website (but not canon europe!) here: http://www.usa.canon.com/consumer/controller?act=ModelInfoAct&tabact=DownloadDetailTabAct&fcategoryid=351&modelid=6624. the version was 7.0.1.1

    Once I had installed this, I could scan images via graphic converter software but not using the canoscan toolbox software - (the latest version I could find of that was 4.1.3).

    Hope this helps!
     
  4. Ryan Griffin macrumors newbie

    Joined:
    Apr 3, 2008
    #4
    Canon Lide 20 Fix

    When I upgraded to the latest version of Tiger 10.4.10 and .11 ... My Canon Lide 20 which had been working perfectly for years just stopped working. I tried to download the latest driver from canon but kept getting errors. After several different attempts I found this posting on version tracker did what it said and it worked!

    "Problems Installing CanonScan Software - Version: 4.1.3, 2/5/2007 06:30AM PST
    (3 of 3 users found this comment useful)

    robert.loney
    For Macintosh OSX users (including intel Macintosh computers) who have problems installing Canon scanner software, including older models. Please try the following steps to successfully install your scanner driver software:

    Short Fix:
    1. Use the "Deldrv" program to remove previously unsuccessfully installed driver(s). The "Deldrv" uninstaller can be found on the Canon website at the bottom of the Canon scanner driver pop up window that you access to get the drivers for your scanner.
    2. Use the "Find?" under the File menu (command-F) or use Spotlight (command spacebar) to find the folder "CFMSupport". Select this folder (don't open it), and use the 'Get info' command in the File menu (command-I) to open information about the Ownership and Permissions of the folder. Click on the arrow beside 'Ownership and Permissions' so it points downwards, then click on the arrow beside 'Details' so you can see the details. Click on the padlock icon so it is unlocked. Then set owner to your user name, set the Group to admin, and set access for all users to Read & Write.
    3. Reinstall the CanoScan Toolbox first, then the scanner drivers from the Canon website or your CD, restart your computer."

    Uninstalling I think made all the difference. I hadn't done that before. Thanks to Robert Loney for this. I was about to purchase VueScan which also worked... but he saved me $49 buckswhich is more than I paid for the Lide 20 5 years ago.

    I also lost my external hard drivers when I upgraded to 10.4.10. never fixed that problem... just went and returned my Western digital Mybooks (both premium and pro additions) (I had been dealing with customer service and returning the ones they kept shipping me for months). I got a Maxtor 750 GB one from Circuit city and it has worked like a charm! I wonder if there was something I needed to uninstall to get that to work as well.

    I hope this is helpful to everyone else out there.
     
  5. lakerbob macrumors member

    Joined:
    Feb 26, 2008
    #5
    I had a similar problem with a canoscan lide 35 and my imac. USA Canon software couldn't find the scanner. Downloaded the software from the European canon site, and now works great
     

Share This Page