Can't access a certain website

Discussion in 'MacBook' started by lynn66, Sep 15, 2011.

  1. lynn66 macrumors newbie

    Joined:
    Apr 17, 2010
    #1
    I need help accessing a certain website. All other sites pop right up. My Macbook gives me the message:
    server www.showsteers.com can't be found(or something like that). I know the site is up and running - we've had people check for us. I use Safari, but loaded Firefox too. Same message. I've deleted history, cookies, cache and the bookmark. I even created a new user. I use a Sprint data card to connect to the internet. Sierra Wireless Compass 597. My Sprint guy couldn't help me. I have a MacBook 10.5.8.
    Thank you for any help you can give me!
     
  2. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
  3. lynn66 thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #3
    No luck

    Restarted the MacBook. Did not help. Thanks
     
  4. maril1111 macrumors 68000

    maril1111

    Joined:
    Mar 14, 2010
    Location:
    Denmark
    #4
    Try google chrome, that works for me everytime firefox and safari fail.
     
  5. lynn66 thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #5
    Tried Chrome

    OK - so I downloaded Google Chrome. This time I got a very interesting message:

    This is Google's cache of http://www.showsteers.com/. It is a snapshot of the page as it appeared on Sep 14, 2011 19:04:20 GMT. The current page could have changed in the meantime. Learn more

    There is no way we were able to access the website on the 14th. It wouldn't go past the snapshot(links didn't work). I forgot to say that we have used this site tons of times before the beginning of Sept.
    I'm going crazy!!!
     

Share This Page