Can't access Apache server except on localhost

Discussion in 'macOS' started by rogersmj, Oct 19, 2007.

  1. rogersmj macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #1
    This is really irritating...I setup a site using the Apache server on my MacBook Pro, and once I did all the CSS and everything I decided I had to check it in IE from Parallels and my Windows machine. Well, I can't access the site from any other machine on my network. I can successfully ping the MacBook, so it seems that just Apache is refusing access. A cursory glance through /etc/httpd/httpd.conf didn't reveal anything obvious, but the file is massive and I'm not sure exactly what to look for. I am not using the machine's firewall, and I've restarted the web service. Any ideas? I've never run into this before.
     
  2. wakerider017 macrumors 68000

    wakerider017

    Joined:
    Sep 20, 2006
    Location:
    US of A
    #2
    You have Personal Web Sharing enabled right?

    Forward port 80 on your router (You shouldn't need this if you are on a home network though)

    Files in your "/Users/Mrrogers/Sites" Folder?

    What kind of error in IE are you getting when using your Win Machine??
     
  3. rogersmj thread starter macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #3
    I appreciate the response, but none of those things have anything to do with my problem. Yes, web sharing is enabled but I'm not using the personal sharing (so my files are not in my Sites folder, they're in the apache document root...and if they weren't in the right spot I wouldn't be able to view the site with http://localhost, would I?). No, I'm not going to forward port 80 on the router because I'm doing this inside the network. I'm quite experienced with networking and it is not a networking problem. I can access a Mongrel Rails server on port 3000 on this machine from my Windows box, and I can ping the machine, so it's definitely isolated to the Apache server.
     
  4. rmh macrumors regular

    Joined:
    Sep 12, 2007
    Location:
    Texas
    #4
    Maybe try using personal web sharing just for kicks to see if it works?
     
  5. rogersmj thread starter macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #5
    Figured it out; I had to set UseCanonicalName to Off in the httpd.conf file.
     

Share This Page