Can't access Disk Utility in recovery mode

Discussion in 'Mac Basics and Help' started by chriscrk, Sep 15, 2014.

  1. chriscrk, Sep 15, 2014
    Last edited: Sep 15, 2014

    chriscrk macrumors 6502a

    chriscrk

    Joined:
    Nov 14, 2011
    Location:
    Planet Earth (?)
    #1
    Nevermind, solver the issue.


    I've been trying to create a partition on my MacBook Pro, however it never works and tells me I must repair my disk in Disk Utility. However, when I try and do that, it doesn't work and suggests I do it in recovery mode.

    I go in to recovery mode (do the whole command+r at startup), and I get this message:

    "The OS X installation couldn't be completed".

    It suggests restarting but I've done it several times and it doesn't work.

    Anyone know what I could do?
    I'm also unable to do a clean install because of this.

    Any help would be greatly appreciated.
     

    Attached Files:

  2. deenamathew macrumors newbie

    Joined:
    Sep 15, 2014
    #2
    Try booting from the original internal disk.
    Use SuperDuper (free for a full clone), or Carbon Copy Cloner (30 day demo) to clone the original disk to the new disk.
    Try booting the cloned new disk.
    Does that work?

    If you now need to upgrade to a new version of Mac OS X, do it as an update to the cloned disk, not a new install.
     
  3. chriscrk thread starter macrumors 6502a

    chriscrk

    Joined:
    Nov 14, 2011
    Location:
    Planet Earth (?)
    #3
    I was able to fix it by booting up into Apple's servers in the end :)
    I had tried it before but it wouldn't connect to my Wifi, but using the ethernet cable I managed, and was able to access Disk Utility. Fixed it all!

    Thanks anyway! :)
     

Share This Page